I have installed Tor Browser following these instructions Tor Browser | torproject.org.

The "Tor Browser" thingy is not in Application > Internet category. I must run the shell script every time. I'd like to use it regularly, thence I would prefer to have it in my GNOME Application menu, or my Unity launcher.

How can I have it handy at all times?

  • There's no need to create a custom Tor Browser launcher anymore because Tor Browser (torbrowser-launcher) is available in the default Ubuntu repositories in Ubuntu 16.04 and later. – karel Dec 12 '17 at 11:21
  • 1
    Interesting but torproject.org/docs/debian.html.en#ubuntu says specifically (and in bold, no less) "Do not use the packages in Ubuntu's universe". – NikLP Apr 20 '18 at 11:21

In the latest version, I managed to do this by

./start-tor-browser.desktop --register-app

from shell within the directory and it created the entry in my applications-menu just fine.

  • Does it work for all executable files? – JulianLai Dec 2 '18 at 14:46
  • 1
    Not quite sure what you mean by that. If you wonder about other programs than tor browser, I would assume that very few of them have implemented the same command. The "--register-app" flag is - as far as I understand - exclusive to the tor browser executable. – Paul Dec 4 '18 at 14:07
  • This instruction is the the script itself. – mathtick Dec 7 '18 at 17:52
  • This is still applicable today.. – Chris Catignani Apr 27 '20 at 22:25

Just open it with whatever script you already used and right click on its icon in unity/menu and choose lock to launcher ;)

OR #2 Option --

based on Ubuntu documentation, just open up the file 'launcher_name_here.desktop' with atext editor e.g, gedit , and then paste these codes, modify them with your application execution scripts and location and then save it:

[Desktop Entry]
Comment=This is my comment

OR #3 Option ---

use the extra gnome application "gnome-panel/alacarte" by this command in terminal :

sudo apt-get install --no-install-recommends gnome-panel and then

gnome-desktop-item-edit ~/Desktop/ --create-new

In any case I would suggest to take a look at my references link above. ;)

  • How can I have it handy with a GNOME interface? – popi Sep 22 '13 at 19:24
  • Take a look at my updated answer ;) – Amir Sep 23 '13 at 14:08
  • If the answer could help you solve your problem please mark it as accepted so that the other guys who have the same problem can benefit from the right answer ;) – Amir Sep 24 '13 at 10:39

Copy the start-tor-browser.desktop configuration, found in the root of the tor-browser installation directory, to ~/.local/share/applications

Job done


Based on Amir's work (put here to preserve formatting, please upvote him if you upvote me), a customised one. Unpack these icons to your Tor folder, assumed to be in home:

[Desktop Entry]
Comment=Launches Vidalea & Tor

Xubuntu: You add it via settings > main menu, new entry, point to 'start tor browser'. It'll go in 'other'. Dunno how to edit that or icon. Seems buggy. Comment if you know what to do.

  1. Open the directory of the tor browser in the file manager. There is a file called: start-tor-browser.desktop
  2. Drag this file to the Unity Launcher on the left side.

An icon is added to the launcher and could be used from now on.


Open file:///usr/share/applications/ then drag the icon you want to the desktop.

  • 1
    It will not work. Do we want to bet? – A.B. Nov 13 '15 at 13:46
  • Worked for me. i think that it could help someone else. – saidc3 Nov 13 '15 at 13:51
  • @saidc3 you found the Tor app in that directory and dragged it to the desktop? – TheWanderer Nov 14 '15 at 22:19

RE: Adding Tor to favorites bar

I was running into a similar problem in Kali Linux, which is based on Ubuntu, and what I found to work was:

1) Download and extract the standalone Tor bundle and extract the whole folder.
2) Navigate to that folder in terminal
3) Copy the entire contents of this folder to /usr/share/applications by running this command:

sudo cp -R *.* /usr/share/applications

4)Go to your main menu, Tor should now be listed under "Internet" category, and launch Tor
5) When Tor launches, you should now be able to right click on the favorites icon and choose "add to favorites"

Anyway, it worked for me and solved both problems of adding it to the menu and favorites.

NOTE: I did this under a sudo enabled account in Kali and NOT root! Not sure if it works under root.

To properly add a new user to Kali, read instructions here:



I have managed to copy "Tor Browser" shortcut to the applications directory. I think it might be similar across Debian based linux system. So, what i did is following steps which are mixed of above suggestions.

  1. when i installed Tor browser, it has a application launcher called "Tor Browser.desktop". I copied this file to /usr/share/applications folder as a root user (I hope it is necessary to be root for this folder).

  2. I renamed this file for just easy purpose so it doesn't have space in the filename, i.e. mv Tor\ Browser.desktop tor-browser.desktop

  3. Then I changed permission to be like -rw-r--r-r which means root user has read and write and all other has only read access to it.

That's all! It works for me and I hope it works for you guys as well.

Also, I am not saying this is best option, but it is the only option it worked for me. Thanks.


Go to the directory where your .desktop file of tor is present.

The run this below command.

./start-tor-browser.desktop --register-app

Now you can go in your "show applications" menu and type tor. You can launch it from here.

Also you can right click on tor in above step to add it in your favorites and it will be added in your task bar menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.