here is my story :-)

i would like to get Bumblebee running with a NVIDIA® GeForce® GT 750M and it does not work. Basically optirun says Failed to initialize the NVIDIA GPU.

I tried many things suggested in here ending in a complete broke X server and unity after using nvidia-xconfig. after a night of debuging my system runs again (i had to reinstall ubuntu-desktop package), but something with the onboard intel chip is now broke too: before i hat 60 fps at glxspheres (running on the intel chip), now its 25fps.

Because GT 750M is not supported in 304, i installed the 319/325 Driver and bumblebee as described here:Using Nvidia 319 with bumblebee ( ppa:xorg-edgers/ppa )

in the following i try to post as much usefull information as possible:


  • Details:http://www.asus.com/Notebooks_Ultrabooks/N550JV/#specifications
  • Processor: Intel® Core™ i7 4700HQ Processor
  • Memory: DDR3L 1600 MHz SDRAM, DIMM 8G
  • Graphic onboard: Integrated Intel® HD Graphics 4600 and
  • Graphic nvidia: NVIDIA®GeForce® GT 750M with 2GB DDR3 VRAM
  • Kernel: 3.8.0-30-generic
  • OS: Ubuntu 13.04 x64

optirun --debug glxspheres

[36773.371123] [DEBUG]optirun version 3.2.1 starting... [36773.371185] [DEBUG]Active configuration: [36773.371198] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf [36773.371211] [DEBUG] X display::8 [36773.371223] [DEBUG] LD_LIBRARY_PATH:/usr/lib/nvidia-325:/usr/lib32/nvidia-325 [36773.371236] [DEBUG] Socket path: /var/run/bumblebee.socket [36773.371248] [DEBUG] Accel/display bridge: auto [36773.371260] [DEBUG] VGL Compression: proxy [36773.371273] [DEBUG] VGLrun extra options:
[36773.371285] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus [36773.371349] [DEBUG]Using auto-detected bridge virtualgl [36773.411550] [INFO]Response: No - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[36773.411588] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[36773.411593] [DEBUG]Socket closed. [36773.411613] [ERROR]Aborting because fallback start is disabled. [36773.411620] [DEBUG]Killing allremaining processes.

dpkg -l|grep nvidia

ii bumblebee-nvidia
3.2.1-1~raringppa3 amd64 NVIDIA Optimus support using the proprietary NVIDIA driver rc nvidia-304
304.108-0ubuntu1~xedgers~raring1 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library ii nvidia-319
325.15-0ubuntu1~xedgers~raring2 amd64 Transitional package for nvidia-319 ii nvidia-325
325.15-0ubuntu1~xedgers~raring2 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library ii nvidia-persistenced
325.15-0ubuntu1~xedgers~raring1 amd64 Load the NVIDIA kernel driver and create device files ii nvidia-settings-319
325.15-0ubuntu1~xedgers~raring2 amd64 Transitional package for nvidia-settings-319 ii nvidia-settings-325
325.15-0ubuntu1~xedgers~raring2 amd64 Tool for configuring the NVIDIA graphics driver

lspci -k | grep nvidia

Kernel driver in use: nvidia

grep -Fn '(EE' /var/log/Xorg.8.log

15: (WW) warning, (EE) error, (NI) not implemented, (??) unknown. 117:[ 36773.400] (EE) Failed to load module "kbd" (module does not exist, 0) 158:[ 36773.409] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please 159:[ 36773.409] (EE) NVIDIA(0): check your system's kernel log for additional error 160:[ 36773.409] (EE) NVIDIA(0): messages and refer to Chapter 8: Common Problems in the 161:[ 36773.409] (EE) NVIDIA(0): README for additional information. 162:[ 36773.409] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device! 163:[ 36773.409] (EE) NVIDIA(0): Failing initialization of X screen 0 168:[ 36773.409] (EE) Screen(s) found,but none have a usable configuration. 172:[ 36773.409] (EE) 176:[36773.409] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information. 177:[ 36773.409] (EE)


Sep 22 09:39:34 talorion-N550JV kernel: [37308.550024] vgaarb: this pci device is not a vga device Sep 22 09:39:34 talorion-N550JV kernel: [37308.550406] nvidia 0000:01:00.0: irq 50 for MSI/MSI-X Sep 22 09:39:34 talorion-N550JV kernel: [37308.563424] NVRM: failed to copy vbios to system memory. Sep 22 09:39:34 talorion-N550JV kernel: [37308.571915] NVRM: RmInitAdapter failed! (0x30:0xffffffff:720) Sep 22 09:39:34 talorion-N550JV kernel: [37308.571923] NVRM: rm_init_adapter(0) failed


KeepUnusedXServer=false XorgConfDir=/etc/bumblebee/xorg.conf.d

[bumblebeed] VirtualDisplay=:8 KeepUnusedXServer=false ServerGroup=bumblebee TurnCardOffAtExit=false NoEcoModeOverride=false Driver=nvidia

[optirun] Bridge=auto VGLTransport=proxy PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus AllowFallbackToIGC=false

[driver-nvidia] KernelDriver=nvidia-319 PMMethod=auto LibraryPath=/usr/lib/nvidia-319:/usr/lib32/nvidia-319 XorgModulePath=/usr/lib/nvidia-319/xorg,/usr/lib/xorg/modules XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

[driver-nouveau] KernelDriver=nouveau PMMethod=auto XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Here are my question(s):

  • How can i go back to my graphical system working as it did right after the installation of ubuntu?
  • How can i get Bublebee run on mys System (or what exactly did i wrong)?

Thank you very much for any help.



after the suggestions of lupopa i installed 12.04 sucessuflly. the problem now is that nvidia prime is not working. why it is not working is decribed here: Is a NVIDIA GeForce with Optimus Technology supported by Ubuntu? . So i think i have to stick with bumblebee wich is still not working :-)

closed as off-topic by Richard, Jorge Castro, Braiam, Danatela, Radu Rădeanu Apr 14 '14 at 4:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.


I was in the same situation as you few days back. I bought a new laptop Lenovo Y510P which had the following specs,

  • CPU: Intel Haswell Core i7 4700HQ
  • Memory: 8GB DDR3
  • Graphics Onboard: Integrated Intel® HD Graphics 4600
  • Graphic Nvidia: NVIDIA®GeForce® GT 755M

My advice (which I read in several places) is that you need to use the latest Ubuntu which in turn comes with the latest Linux kernel. I installed Ubuntu 13.10 (Unity) which comes with Linux Kernel 3.11.1 (at the time of writing this post).

Since I used Ubuntu 13.10, I had several advantages like not requiring to disable Secure Boot or anything. On inserting my installation CD, I pressed F12 to access the UEFI boot order, where I selected CD as the boot medium. I booted into the Live CD environment and things seemed to work well. So I installed it alongside with Windows.

After installing it, I rebooted which resulted in me getting a black screen after selecting Ubuntu from the Grub menu. I had to add the option -nomodeset. This was required since Ubuntu had defaulted to the nouveau drivers. Also I noticed that the brightness option was 0. So try increasing the screen brightness to see the ubuntu booting screen. However despite using the -nomodeset option, I still couldnt get into the login screen.

So I pressed Ctrl + Alt + F2 to get to the tty2 terminal. Here I logged in and installing the following,

sudo apt-get install bumblebee primus primus-libs-ia32:i386 linux-headers-generic

Then reboot the system. You will no longer need to add the -nomodeset option and was able to get to the login screen. I still have the issue of the brightness set to 0 on every boot. At this point, we are still using Intel HD4600 for all purposes alongside with the nouveau drivers.

On reading everywhere, the proprietary drivers for Nvidia are much better than Nouveau for new Nvidia graphic cards in terms of performance. So once logged in, I opened a terminal and executed the following,

sudo apt-get install bumblebee-nvidia nvidia-319 nvidia-settings-319

This will automatically pull in some additional packages as dependencies and ensure that bumblebee uses the nvidia proprietary drivers as default over nouveau. I did not have to edit any config files yet.

Bumblebee is currently our best option for Nvidia's Optimus technology. By default, Ubuntu uses Intel HD4600 for everything. If you want to run a game using Nvidia (not done automatically), append optirun --bridge primus to the command used to launch the game. Using this I am able to run Dota 2 on its highest setting and able to get 50-60 fps.

Hope this helped. I got all the information about bumbleebee at https://wiki.ubuntu.com/Bumblebee.

Note 1: At all costs, do not download the drivers from Nvidia's website and install them manually. If you do so, you will have to install the drivers again everytime there is a linux kernel update.

Note 2: Do not install nvidia-current since it still points at nvidia-304 which is quite old. I still need to figure out how to install nvidia-325 since its a newer driver version and bring more performance improvements.

Note 3: I haven't added the ppa:xorg-edgers/ppa yet since it is not yet available for Ubuntu 13.10. However once it becomes available, I intend to add it to get the latest updates to the intel HD4600 since this card is quite new.

  • thank you for your advice unfortually such "bleeding edge" aproaches are nothing for me right now... i would like to use ubuntu as a productive system and would like to get as much satbility as possible. i managed to get 12.04 installed and i am going to install 14.04 (which is i think the next lts). but the things you mentioned in your post are very helpful so i can partly use them for a different problem - not geting nvidia-prime running. so thank you very much – Gregon Sep 23 '13 at 5:22
  • Have you been able to run the NVIDIA graphics in Ubuntu without bumblebee? I have the same machine and I'm still looking for a solution. – Anton Petrov Oct 2 '13 at 15:03
  • @AntonPetrov May I ask why you do not want to use bumblebee? Bumblebee allows you to use your intel GPU for normal tasks and switch to Nvidia only for graphic intensive tasks such as gaming etc easily with the optirun command. – nik90 Oct 4 '13 at 12:54
  • @Nik, a very simple example would be if you want to run a virtual machine with Windows and want to play games inside it. And I think that Bulblebee doesn't use the full potential of your GPU, if I'm not wrong. – Anton Petrov Oct 5 '13 at 13:12
  • @AntonPetrov I haven't tried without bumbleebee because I do not want my nvidia card being used all the time since that would result in lower battery time. For virtual machine, if you open the vmware app using optirun, it will run the virtual machine using the nvidia driver. I still bumblebee will help you. – nik90 Nov 7 '13 at 12:16

Install Linux Ubuntu 12.04.3 as new - Ubuntu using Nvidia Optimus as first device ;) And you don't need Bumblebee...

Greetings Lupopa

  • i would like to use Ubuntu 12.04 because of the LTS, but it won't boot because of my uefi. to be mor specific: i created a bootable usb stick with 12.04 and after i chose "try ubuntu " all i got was a black screen. Doing the same with 13.04 got me ito a running system. – Gregon Sep 22 '13 at 9:16
  • Use Key: Fn & Cursor right... After Installation edit /etc/default/grub and change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash " to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" or GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" – lupopa Sep 22 '13 at 10:30
  • 1
    Thank yoy for the tips. ifinally got 12.04 running, but unfortunally as soon as i install the nvidia prime packet the os boots only in low graphics mode. But i am foing to investigate on this. – Gregon Sep 23 '13 at 5:17

Got it working with my GT745M here on Ubuntu 13.10 on my Toshiba Satellite P50-A-11K laptop.

Not sure what is required, but here is what I did.

Installed drivers bumblebee and headers

sudo apt-get install nvidia-331 bumblebee linux-headers-generic  

Open bumblebees config-file in gedit:

sudo gedit /etc/bumblebee/bumblebee.conf  

Replace matching keywords with these values:


Save and exit

I then removed 304-driver

sudo jockey-text -d kmod:nvidia_304

Then reconfigure some stuff, by running this and pressing ok.

sudo pam-auth-update --force


This was a longshot, but the virtualGL-backend seem to be missing in 13.10, so I downloaded and install it from here: http://sourceforge.net/projects/virtualgl/files/VirtualGL/2.3.3/

Once downloaded, install in a terminal using:

sudo dpkg -i virtualgl_2.3.3_amd64.deb

optirun will now prefer virtualgl over primus (if bridge is set to auto or virtualgl in bumblebees configfile), and with the virtualgl-backend it seems to work fine.

Some output:

r@i7:~$ optirun -vvv glxgears  
[ 2396.043994] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf  
[ 2396.044237] [INFO]Configured driver: nvidia  
[ 2396.044318] [DEBUG]optirun version 3.2.1 starting...  
[ 2396.044325] [DEBUG]Active configuration:  
[ 2396.044328] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf  
[ 2396.044331] [DEBUG] X display: :8  
[ 2396.044334] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-331:/usr/lib32/nvidia-331  
[ 2396.044337] [DEBUG] Socket path: /var/run/bumblebee.socket  
[ 2396.044340] [DEBUG] Accel/display bridge: auto  
[ 2396.044342] [DEBUG] VGL Compression: proxy  
[ 2396.044345] [DEBUG] VGLrun extra options:   
[ 2396.044348] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus  
[ 2396.044372] [DEBUG]Using auto-detected bridge virtualgl  
[ 2397.989470] [INFO]Response: Yes. X is active.  

[ 2397.989482] [INFO]Running application using virtualgl.  
[ 2397.989561] [DEBUG]Process vglrun started, PID 3727.  
7045 frames in 5.0 seconds = 1408.869 FPS  
6834 frames in 5.0 seconds = 1366.776 FPS  

Not the answer you're looking for? Browse other questions tagged or ask your own question.