4

I want to install the latest versions of curl, php5-xmlrpc and php5-intl extensions for php 5.4. I have the latest version of php 5.4 (installed via ppa:ondrej/php5-oldstable) so the default precise packages for the said extensions will not work. I know this because I tried that first and also tried packages for later versions such as 12.10 and 13.04.

Question is how do I install the latest versions of this extensions and where do I get them from. Any help will be appreciated.

3

php5-xmlrpc is bundled into PHP as of 4.1.0: http://php.net/manual/en/xmlrpc.installation.php

php5-intl is too as of PHP 5.3.0: http://www.php.net/manual/en/intl.installation.php

For curl, you'll need to install a few more libraries to get it to work:

 sudo apt-get install curl libcurl3 libcurl3-dev php5-curl
  • thanks, but as I already said, the defaults in repos do not work since I have the latest version of php (5.4). That would work fine for someone with php 5.3 but not in my case :( – mojo706 Sep 22 '13 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.