I'm using Ubuntu 13.04 (Raring)

I've installed CompizConfig Settings Manager (CCSM) and wanted to enable the wobbling window effect. This disabled some other things and suddenly I didn't have window borders any more... Following various instructions I found at Google, I've tried the following steps:

  1. Go to CCSM Preferences / Reset to defaults

This disabled all plugins and effects (including Unity) so I didn't get any further...

  1. executing dconf reset -f /org/compiz and rebooting

This brought borders back, but still don't have close/mini/maxi buttons, can't resize or move windows. And the top left entries of the menu bar vanished (Logout, battery, volume...) so I have to shutdown my computer via a terminal...


  1. Following the instructions from the first answer.

This brought my menu bar applets back... dpkg-reconfigure didn't seem to work. Result of this command:

/var/lib/dpkg/info/compiz.config: 1: /var/lib/dpkg/info/compiz.config: [general]: not found
/var/lib/dpkg/info/compiz.config: 2: /var/lib/dpkg/info/compiz.config: backend: not found
/var/lib/dpkg/info/compiz.config: 3: /var/lib/dpkg/info/compiz.config: plugin_list_autosort: not found
/var/lib/dpkg/info/compiz.config: 5: /var/lib/dpkg/info/compiz.config: [gnome_session]: not found
/var/lib/dpkg/info/compiz.config: 6: /var/lib/dpkg/info/compiz.config: backend: not found
/var/lib/dpkg/info/compiz.config: 7: /var/lib/dpkg/info/compiz.config: integration: not found
/var/lib/dpkg/info/compiz.config: 8: /var/lib/dpkg/info/compiz.config: plugin_list_autosort: not found
/var/lib/dpkg/info/compiz.config: 9: /var/lib/dpkg/info/compiz.config: profile: not found
/var/lib/dpkg/info/compiz.config: 11: /var/lib/dpkg/info/compiz.config: [general_ubuntu]: not found
/var/lib/dpkg/info/compiz.config: 12: /var/lib/dpkg/info/compiz.config: backend: not found
/var/lib/dpkg/info/compiz.config: 13: /var/lib/dpkg/info/compiz.config: integration: not found
/var/lib/dpkg/info/compiz.config: 14: /var/lib/dpkg/info/compiz.config: plugin_list_autosort: not found
/var/lib/dpkg/info/compiz.config: 15: /var/lib/dpkg/info/compiz.config: profile: not found

Is there any possibility to reset the settings like they were after installing Ubuntu?

Edit 2:

Just noticed that the title bar of windows isn't missing; It's just hidden under the menu bar. So the buttons are only hidden, too.


Started CCSM, went to window management and checked scale windows and move windows... After a re-login everything was fine.


Execute the following command and then re-login:

rm  -rf ~/.compiz-1 ~/.config/compiz-1
  • I think it will remove all settings, not only unity
    – fikr4n
    Jan 24 '14 at 11:04
  • 1
    Then you only rm .compiz-1 and .config/compiz-1
    – s3lph
    Jan 24 '14 at 21:32
  • Maybe you should revise this answer as per your comment above... I used to see Ubuntu's default background for one or two seconds on startup. Removing ~/.compiz and ~/.config/compiz-1 got rid of this problem as well (although I still see it after logoff and login). Thanks :-)
    – Sadi
    May 3 '15 at 7:19
  • or you can easily create a new profile or set it to default Apr 7 '17 at 18:21

The script is now bundled with Unity Tweak Tool. You can install it using

sudo add-apt-repository ppa:freyja-dev/unity-tweak-tool-daily
sudo apt-get update
sudo apt-get install unity-tweak-tool

To reset Unity, do

unity-tweak-tool --reset-unity
  • 1
    This worked (eventually, had to log in and out, set DISPLAY=:0)! Thank you! No thanks to unity being flaky and unfriendly.
    – Steven Lu
    Mar 9 '17 at 22:12

You probably are missing this last command:

unity --reset-icons

Look at this link:


Hope it helps


  • Doesn't show any effect after relog/reboot
    – s3lph
    Sep 21 '13 at 20:20
  • This is the command that saved it for me!
    – Max
    Sep 21 '16 at 9:51

what worked for me is the solution described in the link posted by Mário:



 sudo apt-get install dconf-tools
 dconf reset -f /org/compiz/
 unity --reset-icons

and login again


Open a Terminal and type:

$ sudo dpkg-reconfigure compiz

an relogin...

or type in Terminal for compiz standard:

$ gconftool-2 --recursive-unset /apps/compiz $ rm -rf ~/.compiz

  • This brought the menu bar applets back... the other problems remain.
    – s3lph
    Sep 21 '13 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.