I am using Ubuntu 12.04. I can install v2.8.6.3 of Monodevelop from software center but I need at least v3 to use Monogame v3 or higher. Can anyone point me in the right direction please?


  • Actually if you go to the «installation» section of theMonoDevelop's site, you will see there an official PPA for Debian and derivatives. – Hi-Angel Apr 21 '15 at 9:04

Installing Mono develop 4 on 12.04 precise

Option 1: Compile Git version from source

First uninstall your current version of mono develop with the software centre then from the terminal run following commands:

sudo apt-get install build-essential automake checkinstall intltool git
sudo apt-get install mono-complete mono-addins-utils gtk-sharp2 gnome-sharp2
git clone git://github.com/mono/monodevelop
cd monodevelop
git checkout monodevelop-4.0
git submodule update --init --recursive
sudo checkinstall

Option 2: Installing from PPA

Un-install current version first

sudo add-apt-repository ppa:keks9n/monodevelop-latest
sudo apt-get update
sudo apt-get install monodevelop-latest

From terminal run:

  • I gave up on monodevelop long ago but just saw your reply and decided to install anyway. I tried option1 and completed all steps succesfully but in the end I am unable to use monodevelop. There isn't any icon etc. to start it. – sercan Oct 19 '13 at 0:21
  • 1
    So going to the terminal and typing monodevelop pressing enter didn't start it up? – damien Oct 20 '13 at 15:16
  • It did work, thanks. :) I didn't know you can start it just like that. Total newbie here. – sercan Oct 20 '13 at 23:15
  • 1
    The ppa you mentioned is outdated (at least the stable version).. The ppa linked in Salv0's answer is much better... – nedR Feb 15 '14 at 12:29
  • I'm getting an error compiling it from source: Metadata file '/usr/local/lib/mono/monodoc/monodoc.dll' could not be found – Jeroen Bollen Mar 7 '14 at 16:23

The ppa from the first answer


seems to be outdated.

If you want to use the latest version ( 4.2.2+ ) with the latest runtime and so on, I suggest to use this new ppa:

sudo add-apt-repository ppa:ermshiperete/monodevelop
sudo apt-get update
sudo apt-get install monodevelop-current

After this you will have monodevelop installed in the /opt/monodevelop. To start the IDE use the following script:

  • 2
    Thanks, this worked perfectly. To launch it, create a mono.desktop file with the following code: [Desktop Entry] Type=Application Name=Mono Develop Exec='/opt/monodevelop/bin/monodevelop-launcher.sh' Terminal=false – Jack M. May 2 '14 at 23:43
  • Careful with this: it doesn't add basic stuff like mono and build to the path, F# doesn't seem to build, F# binding is not yet supported under MonoDevelop 5. – Mauricio Scheffer Aug 25 '14 at 22:41
  • s/build/xbuild. – Mauricio Scheffer Aug 26 '14 at 17:37
  • Thanks, this made installation of a new workstation faster! – Michael Nov 30 '14 at 14:21

You can download the source code from here and compile it. I am using 13.04 and the version of mono is on the software center.

You can try to download from the 13.04 center for your distro (from here)

  • I downloaded the source code but I can't compile it. I am stuck on step 2 here. I extracted the files to /usr/local/src and also got repositories from github but I don't know what to do with them. – sercan Sep 21 '13 at 16:26
  • I removed and tried to download from the link you provided. I got back. – sercan Sep 21 '13 at 19:33

protected by Community Apr 8 '14 at 0:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.