5

I've tracked down a game named superhot and downloaded zipped Linux version. I unzipped it and there was a directory named SUPERHOT-LINUX_Data and file with extension .x86. I went to properties and ticked "can execute". But the file still doesn't start. All i can see is bunch of processes starting upon clicking on that file. Their names starts with unity.

Should i install some libraries or something?

Thanks for advice

Edit: I've tried as damien said and mono installed successfully, but still nothing. Then i tried running that file from terminal:

$ ./SUPERHOT-LINUX.x86

and it returned:

./SUPERHOT-LINUX.x86: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

I guess something is missing?

  • I downloaded the zip file and had a look in the superhot-linux-data directory and it appears you need mono. Try sudo apt-get install mono-runtime then repeat what you tried and report the results to your question – damien Sep 21 '13 at 11:58
  • @tiwy have you solved your problem? – Salem Oct 7 '13 at 13:56
  • well actually i downgraded my linux to 12.04. And it worked. But on 13.04 none of suggestions worked. – aljazerzen Oct 8 '13 at 18:02
7

I solved by installing these libraries:

$ sudo apt-get install libglu1-mesa:i386 libxcursor1:i386

You can print shared library dependencies with:

$ ldd SUPERHOT-LINUX.x86
| improve this answer | |
  • 1
    the ":i386" makes the difference.. – Tapper Mar 19 '14 at 19:18
  • You can improve your answer by explaining why, as @Tapper said, is i386 part important. – Igor V. Jul 22 '17 at 16:30
2

Yes, your system lacks that library (libGLU). In this case it is available in the repositories so you just need to run

$ sudo apt-get install libglu1-mesa

If you find similar errors you can try to find the needed package using apt-file. In this case, to search packages that have the file libGLU.so.1:

$ apt-file search libGLU.so.1
libglu1-mesa: /usr/lib/x86_64-linux-gnu/libGLU.so.1
libglu1-mesa: /usr/lib/x86_64-linux-gnu/libGLU.so.1.3.08000
libglu1-mesa: /usr/lib/x86_64-linux-gnu/libGLU.so.1.3.08004
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.