0

I have installed 12.04.3 in my HP DV6 7040tx. It has quad speakers + one sub woofer (Beats Audio). I went through many posts and i was not able to find the solution. I tried the package

    hda-jack-retask

But, i can hear only much of bass like voice and music.

Here are the configuration when i run lspci | grep "Audio"

    00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

when i run cat /proc/asound/card0/codec#* |grep Codec

    Codec: IDT 92HD91BXX
    Codec: Intel PantherPoint HDMI

when i run aplay -l

    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

when i run lspci -v | grep -A 8 -i audio

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
Subsystem: Hewlett-Packard Company Device 1818
Flags: bus master, fast devsel, latency 0, IRQ 47
Memory at d4610000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4) (prog-if 00 [Normal decode])

Can i get a solution to make use of my beats audio in Ubuntu. Thank you for trying to help me

0

I have a HP Envy dv7 with beats audio, probably similar sound hardware.

In Ubuntu 12.04 I got it working by doing gksudo gedit /etc/modprobe.d/alsa-base.conf and adding the line options snd-hda-intel model=ref at the bottom, then save the file and reboot.

Now under Ubuntu 14.04 this solution doesn't work anymore for me, but I found a solution on this thread in the Gentoo forums:

  • do gksudo gedit /etc/pulse/default.pa
  • add the line load-module module-combine channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe at the bottom
  • save the file, close all windows and reboot
  • open sound settings (through system settings or by clicking on the volume icon in unity and choosing "sound settings") and you'll have an extra configuration "simultaneaous sound output". Click on this, then test the sound using the "test sound" button to the right. For me 5 speakers out of 6 work now, only the subwoofer doesn't. Not perfect, but close.

Hope this helps...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.