3

I get this error when I try to convert an wmv to 3gp using this command:

ffmpeg -y -i "inputvid.wmv" -vf scale=352:288 \
       -f 3gp -vcodec h263 -r 15 -b:v 200k \
       -acodec libvo_aacenc -ac 2 -ar 32000 -b:v 64k \
       "outputvid.3gp"

(The command is actually derived from Mobile Media Converter 1.8.2 which recently fails on each conversion and I'm trying to troubleshoot.)

I have made the latest stable ffmpeg (version 0.10.8-7:0.10.8-1~raring1) using these instruction.

I appreciate your hints to either install libvo_aacenc, or some other codec to make conversion possible.

2

This solves it for me:

sudo apt-get install libavcodec-extra

Maybe this post has an answer, but for Googlers...

| improve this answer | |
1

Ok, to make the command work, I just needed to revert the install (Reverting Changes Made by This Guide) and start again but add '--enable-libvo-aacenc' to ffmpeg .configure flags.

| improve this answer | |
  • 3
    If you've gone to the trouble of compiling it yourself anyway, you might as well use libfdk_aac instead, as it will give you much better quality audio. – evilsoup Sep 21 '13 at 11:18
  • 3
    Agreed. In fact, libvo_aacenc is worse than the native FFmpeg AAC encoder (-codec:a aac -strict experimental) which is currently being worked on and is improving. – llogan Oct 2 '13 at 20:32
  • Now aac is no longer experimental, so -strict is not needed. – llogan Jan 12 '16 at 23:48
1

libvo_aacenc was low quality and FFmpeg removed support for this encoder.

Use -c:a aac or -c:a libfdk_aac instead.

See FFmpeg Wiki: AAC for more info.

| improve this answer | |
-1

It's Easy
Only Follow the next instructions
Open the terminal
cd ~
wget http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
tar xjvf ffmpeg-snapshot.tar.bz2
cd ffmpeg
PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig"
export PKG_CONFIG_PATH
./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" \ --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --extra-libs="-ldl" --enable-gpl \ --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus \ --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-x11grab --enable-libvo-aacenc --enable-version3
(IN this part you have been enabled the libvo-aacenc & the version 3 of the same)
make
make install
make distclean
hash -r
Your converter is ready.

| improve this answer | |
  • Looks like you copied and pasted this from the FFmpeg Wiki and added --enable-libvo-aacenc --enable-version3. – llogan Sep 27 '17 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.