44

I want to change my default shell from tcsh to bash. So I tried and this is what happened:

>sudo chsh userid
Changing the login shell for userid
Enter the new value, or press ENTER for the default
        Login Shell [/xhbin/tcsh]: /bin/bash
chsh: user 'userid' does not exist in /etc/passwd

Indeed, I am not in /etc/passwd. I don't know why.

What can I do?

1
  • 12
    Is your system using distributed authentication (e.g. kerberos / winbind)? In that case your user details would not appear in the local /etc/passwd file (but should be visible using getent passwd <userid>). I think that whether running chsh is supported in that case may depend on settings in /etc/pam.d/ Sep 21 '13 at 13:28
23

My computer is part of a network using using distributed authentication so my user details would not appear in the local /etc/passwd file (but are visible using getent passwd userid). (thanks @steeldriver) In my case I had to do chsh on a core machine.

5
  • 13
    can you explain what a "core machine" is? Jan 23 '14 at 8:49
  • In my case I'm referring to a set of dedicated machines provided by the university inside their network that students can log into and use (shared). As opposed to my own machine in my office.
    – rmp251
    Jan 23 '14 at 17:12
  • 7
    @rmp251 This is exactly my scenario is. I don't have access to the core machine. Did you find a way to change the shell otherwise?
    – Geek
    Feb 23 '18 at 14:46
  • @Geek did you find the way how to solve it?
    – milushov
    Aug 12 '19 at 23:05
  • Better late than never. My workaround was to open my terminal preference, select the Unnamed profile, in the "Command" menu, check the box "Run a custom command instead of my shell" and type "/bin/zsh" as command
    – Wiwwil
    Sep 6 at 9:57
23

There is a workaround for gnome-terminal:

  1. Go to EditProfile preferencesTitle and Command.
  2. Check Run a custom command instead of my shell.
  3. Provide bash as the Custom command (or fish, or anything).
2
  • Thanks! Supplying a command to run immediately when I open my terminal (or new terminal tab) via the settings worked for me.
    – cacoder
    Apr 10 '18 at 20:24
  • This also works for Konsole and yakuake in KDE.
    – xgdgsc
    May 31 '19 at 1:16
9

If you are using LDAP authentication by PAM or something, you have to find your answer in your LDAP Server. Let's aim it for Microsoft AD, in which case your domain account is not in /etc/passwd when you log in, but you can see your user property in AD, by getent passwd | grep user.

If at the end it shows your shell is /bin/csh, that's because in your AD there is a attribute for that. So if you have administrator account on AD, you can fix it yourself. Otherwise just tell your AD admin to enable advance features in the View tab of Active directory users and computers > User properties > UNIX attributes. There you can change the login shell to /bin/bash.

Be sure you don't forget to run:

sudo /opt/pbis/bin/config LoginShellTemplate /bin/bash

Source: User does not exist in /etc/passwd when trying to change the default shell.

1
  • 2
    Question was to change shell for one user, whereas pbis config changes for all users.
    – kubanczyk
    Aug 4 '16 at 13:06
5

If you want to change the shell for your user, you do not need to become root. Just type:

chsh

without sudo and without arguments.


See also man chsh:

The chsh command changes the user login shell. This determines the name
of the user's initial login command. A normal user may only change the
login shell for her own account; the superuser may change the login
shell for any account.
3
  • The reason I used sudo was because it didn't do anything without it. > whoami userid > chsh You may not change the shell for 'userid'.
    – rmp251
    Jan 10 '14 at 19:31
  • The reason it works is that chsh does not work with kerberos Sep 6 '19 at 7:54
  • 1
    Still fails: chsh: user "walshcaadmin" does not exist.
    – Carl Walsh
    Mar 17 at 19:25
5

If you are trying to ssh into a remote host with a domain user, you might not be able to change your shell using chsh as @Masoud mentioned. But here is a simple workaround for this case - whenever you ssh into the machine, do this:

ssh my-host -t "zsh --login"

or

ssh my-host -t "cd /data/repos; zsh --login"

If you also want to login directly into a different working dir.

Edit:

Another simple option that does not require ssh command manipulation:

  • Edit your profile file: vi ~/.profile
  • Launch your favorite shall by calling it at the last line, e.g. zsh
  • Save and quit (:wq)

This solution also has the advantage that it persists when creating new sub-shells, for example when using tmux.

3

My machine is using LDAP authentication and I don't have access to the server. So my workaround was to change $SHELL variable to zsh at the end of my .bashrc file. $SHELL=/bin/zsh $SHELL So for me when I open terminal bash opens zsh.

2

If you forgot your user name, you can use whoami command to remember you.

So, try with:

sudo chsh $(whoami)

If indeed, doesn't exist a line starting with your user name in /etc/passwd file (which seems inexplicable), you can add a new one like this:

username:x:1000:1000:your real name,,,:/home/username:/bin/bash

See also: Understanding /etc/passwd File Format.

1
  • 3
    One reason your user might not exist in /etc/passwd is if authentication is not handled on that machine (e.g. ldap) Feb 23 '18 at 16:55
1

This answer helped me.

In your ~/.profile add

if [ "$SHELL" != "/bin/bash" ]
then
    export SHELL="/bin/bash"
    exec /bin/bash -l    # -l: login shell again
fi

Or whatever other shell you want to use

0

Open the file ~/.bashrc and add this at the end :

# Run zsh
if [ "$SHELL" != "/usr/bin/zsh" ]
then
    export SHELL="/usr/bin/zsh"
    exec /usr/bin/zsh
fi

Don't forget to configure zsh :

  • By typing "zsh" in a bash terminal.
  • Or by creating the file ~/.zshrc with default content

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.