14

I have ubuntu 12.04, and 2 languages on my keyboard. Every time the screen goes black it requires my password, which is in English. But the language set is the one I have used last. How can I make it use English by default in the login screen? I am also ok with no password, it is my home computer.

  • There is a very very simple solution. Let's suppose you log out and the keyboard language is not English or Latin which you use for your default password, but something else, for example Greek, or Russian, or Arabic or Hebrew etc. If you try to login, you will have problem because you will need English-latin keyboard, but you will have something else, and you will not able to change it. So the simple solution: Just get in tty and then return in GUI directly. askubuntu.com/questions/979027/… So in my case ubuntu 18.10 ctrl + – Konstantinos Dec 13 '18 at 12:50
  • There is an issue on that on LauchPad: you can follow it: bugs.launchpad.net/unity/+bug/1286910 – Roman Bekkiev Jul 12 at 13:17
1

Disable password on startup

To disable asking for your password when booting your computer we can change the user settings from System Settings... - User Accounts (accessible from the menu in the top right corner when clicking on the cogwheel).

enter image description here

  • To change user settings unlock first on the top right (your password will be asked).
  • Switch "Automatic Login" to ON as shown above.
  • On next reboot you will automatically log into your account without the need to enter a password (after a log out you will have to enter your password again to log in)
  • This menu is also the place to define a user's preferred language.

Disable password on screensaver lock

To disable this security feature open System Settings... - Brightness and Lock:

enter image description here

  • Untick the option "Require my password when waking from suspend"

Notes:

  • Only do this if your computer is in a secure place.
  • Leave at least one account type (your's) as "Administrator".
  • You password will still be asked on administrative tasks.
  • If you manually lock the screen using Ctrl + Alt + L you will still have to enter your password to unlock.
| improve this answer | |
  • 5
    The question seems to be asking about how to lock the login shell language into english, not how to turn the password protection off completely. – Ixanezis Jun 15 '18 at 17:58
  • @Ixanezis rather unclear to me... passwords don't usually follow language locale settings. – Takkat Jun 15 '18 at 18:05
  • that makes sense, thank you for clarification. – Ixanezis Jun 18 '18 at 23:02
4

There is an alternative solution for the problem. You can disable all languages system-wide, except English, but leave the languages for your current user. I'm using Ubuntu 17.10.

  1. Go to Settings -> Region & Language -> Manage Installed Languages.

enter image description here

  1. Remove all languages using "Install / Remove Languages..." button, except English (only "русский" in my case).

  2. Apply settings system-wide.

  3. Re-install languages that were removed on step 2.

| improve this answer | |
2

This is still an issue on Ubuntu 18.04. None of the answers above worked for me so I've created this mini package to fix the problem

https://github.com/Idan-/magicLockLayout

Please read the instructions first.

| improve this answer | |
  • Doesn't seem to work with 20.04. =( – Roman Bekkiev Jul 12 at 13:06
1

You can change the login keyboard preferences using System Settings, Region and Language, System tab:

enter image description here

Here you click Copy Settings. You should make sure that the current layout is english, otherwise you will stick with the previous layout. It will ask you for your password.

Once you have done this, log out and check if the settings are right.

| improve this answer | |
  • 2
    As I see in my Ubuntu 16.04 there is no Region and Language entry in Settings, only Language support and System tab isn't there – renadeen Mar 11 '18 at 9:21
1

I had a similar issue having 2 keyboards English and Arabic on my Ubuntu 18.04.

I switched from LightDM to GDM3 on Ubuntu 18.04 which helped. Now I can switch language from the login screen.

if you don't have GDM3 you can install with

sudo apt-get install gdm3

to switch from LightDM to GDM3 run:

sudo dpkg-reconfigure lightdm

Enter the password if asked then in the dialog click ok and then select GDM3 and press ok again.

Restart the system.

Hope that helps!

| improve this answer | |
0

I am also using 2 languages on my Ubuntu 16.04.

I wrote a short script that automatically switches input language to US on screen lock.

This script works flawlessly on Ubuntu 16.04. On 18.04, however it doesn't :(, will try to modify it soon.

| improve this answer | |
-1

Havent tried output but I think you can try with something like this:

command:

gksu gedit /etc/lightdm/lightdm-gtk-greeter.conf

search for the line:

#show-language-selector=false         --(false or true)chose appropriate one for you

Change it to:

show-language-selector=true

Save and exit. Logout / Login or reboot the machine to apply the effect.

| improve this answer | |
  • 4
    I think I was not clear enough. I do have language selector, I just want the language to be English without me having to change it. – user1637056 Sep 20 '13 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.