1

I'm new to Ubuntu, just installed Mythbuntu 12.04.3 (64-bit) from an iso (single fontend/backend combo). Seemed to instal fine, rebooted my machine only to find I was faced with a screen asking for country and language information (fine; UK, English).

However, the next screen says 'MythTV cannot connect to database' and I am presented with a form (one of two), which already contains data (hostname, password...) so change nothing. I click next (to get to screen two of two) again change nothing (both check boxes are left unticked) and click finish. This sends me back to the original country/language screen.

Is there a fault with the install? Have I missed something in the install/instructions? Is there a way of fixing this?

Appreciate your answers.

0

Edit your /etc/mysql/my.cnf and /etc/mysql/conf.d/mythtv.cnf files so that the bind address is your server address (the local network address) and not the loopback address (127.0.0.1).

Once you reboot it should connect. If you're unsure what the password is, nano /etc/mythtv/mysql.txt -- the password is in there.

0

To get mythbackend to connect to mysql on Ubuntu LTS 14.04.5, I had to manually change the setting in /etc/mythtv/config.xml to the MySQl password. In my case, USER=mythtv | PASSWORD=mythtv, as per the GUI setup screen for mythtv, but that did not match the default values given in the XML file.

Here's what things looked like after the edits were made:

<Configuration>
  <Database>
    <PingHost>1</PingHost>
    <Host>localhost</Host>
    <UserName>mythtv</UserName>
    <Password>mythtv</Password>
    <DatabaseName>mythconverg</DatabaseName>
    <Port>3306</Port>
  </Database>
  <WakeOnLAN>
    <Enabled>0</Enabled>
    <SQLReconnectWaitTime>0</SQLReconnectWaitTime>
    <SQLConnectRetry>5</SQLConnectRetry>
    <Command>echo 'WOLsqlServerCommand not set'</Command>
  </WakeOnLAN>
</Configuration>

After that, invoking the mythtv back end manually from the command line (shown below) seemed to show that, at least, mythtv could connect successfully to MySQL:

# mythbackend
2017-02-25 12:41:15.716242 C  mythbackend version: fixes/0.27 [v0.27-193-g8ee257c] www.mythtv.org
2017-02-25 12:41:15.716477 C  Qt version: compile: 4.8.6, runtime: 4.8.6
2017-02-25 12:41:15.716485 N  Enabled verbose msgs:  general
2017-02-25 12:41:15.716511 N  Setting Log Level to LOG_INFO
2017-02-25 12:41:15.728628 I  Setup Interrupt handler
2017-02-25 12:41:15.728649 I  Setup Terminated handler
2017-02-25 12:41:15.728666 I  Setup Segmentation fault handler
2017-02-25 12:41:15.728683 I  Setup Aborted handler
2017-02-25 12:41:15.728696 I  Setup Bus error handler
2017-02-25 12:41:15.728711 I  Setup Floating point exception handler
2017-02-25 12:41:15.728724 I  Setup Illegal instruction handler
2017-02-25 12:41:15.728743 I  Setup Real-time signal 0 handler
2017-02-25 12:41:15.728820 N  Using runtime prefix = /usr
2017-02-25 12:41:15.728839 N  Using configuration directory = /root/.mythtv
2017-02-25 12:41:15.728962 I  Assumed character encoding: en_HK.UTF-8
2017-02-25 12:41:15.729455 N  Empty LocalHostName.
2017-02-25 12:41:15.729471 I  Using localhost value of silver
2017-02-25 12:41:15.734868 I  Added logging to the console
2017-02-25 12:41:15.746596 N  Setting QT default locale to en_HK
2017-02-25 12:41:15.746702 I  Current locale en_HK
2017-02-25 12:41:15.746798 E  No locale defaults file for en_HK, skipping
Table 'mythconverg.settings' doesn't exist
2017-02-25 12:41:15.751405 E  Error preparing query: SELECT data FROM settings WHERE value = :VALUE AND hostname = :HOSTNAME
2017-02-25 12:41:15.751426 E  Driver error was [2/1146]:
QMYSQL3: Unable to prepare statement
Database error was:
Table 'mythconverg.settings' doesn't exist
2017-02-25 12:41:15.752399 I  No current database version?
2017-02-25 12:41:15.752931 I  Database appears to be empty/new!
2017-02-25 12:41:15.752964 I  The database seems to be empty - not attempting a backup
2017-02-25 12:41:15.784350 N  Inserting MythTV initial database information.
2017-02-25 12:41:15.784401 C  Upgrading to MythTV schema version 1307
2017-02-25 12:41:15.839389 I  New Client:  (#1)
2017-02-25 12:41:20.656220 C  Upgrading to MythTV schema version 1308
2017-02-25 12:41:20.739196 C  Upgrading to MythTV schema version 1309
2017-02-25 12:41:20.743457 C  Upgrading to MythTV schema version 1310
2017-02-25 12:41:20.745158 C  Upgrading to MythTV schema version 1311
2017-02-25 12:41:20.808532 C  Upgrading to MythTV schema version 1312
2017-02-25 12:41:20.813258 C  Upgrading to MythTV schema version 1313
2017-02-25 12:41:20.877572 C  Upgrading to MythTV schema version 1314
2017-02-25 12:41:20.880266 C  Upgrading to MythTV schema version 1315
2017-02-25 12:41:20.881536 C  Upgrading to MythTV schema version 1316
2017-02-25 12:41:21.006324 C  Upgrading to MythTV schema version 1317
No setting found for this machine's BackendServerIP.
Please run setup on this machine and modify the first page
of the general settings.
2017-02-25 12:41:21.502112 I  Database schema upgrade complete.
2017-02-25 12:41:21.504143 I  Loading en_us translation for module mythfrontend
-1

I have had the same problem and the only solution I have found is to install mythbuntu. There seems to be some sort of a secret mythtv sect that requires a magic decoder ring or special handshake or something in order to give up the answer to this oft-asked question. I have a mythbuntu installation running and it does work but I have never been able to get mythtv to work on an existing desktop.

  • Can you try searching for the specific package? – Kaz Wolfe Dec 30 '13 at 3:48
  • How does this help? The question clearly states that the system was installed from a Mythbuntu ISO. – David Edwards Jan 16 '14 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.