I have some quiet time so I'm finally trying to upgrade my Ubuntu 11.10 installation to something newer (something that's not out of support, even). I'm trying to upgrade to 12.04.

When using the Update Manager, it gets stuck downloading one particular package (number 2057 of 2258, but I suspect that's not useful information to anyone).

So I switched to trying do-release-upgrade from the command line. This gives more information. The problem is with the linux-firmware package. The download gets to 99% and then it stops and starts again. It never completes.

I thought I could get round the problem by downloading the .deb manually and putting it in /var/cache/apt/archives. But I've tried a number of the mirrors given here and I always get something like this:

# wget http://security.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.79.6_all.deb
--2013-09-19 10:53:08--  http://security.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.79.6_all.deb
Resolving localhost...
Connecting to localhost||:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: 23217718 (22M) [application/x-debian-package]
Saving to: `linux-firmware_1.79.6_all.deb'

99% [=====================================> ] 23,207,936  3.40M/s   in 6.5s    

2013-09-19 10:53:14 (3.40 MB/s) - Connection closed at byte 23207936. Retrying.

... and then the download starts again. And again. And again. Until I get bored and cntl-C. I assume that's why do-release-upgrade gets stuck in a loop too.

It seems to me that either the deb file is truncated on the mirrors, or the download is expecting a file that is larger than it really is.

Can anyone suggest how I can get round this and complete my upgrade?

1 Answer 1


Your proxy is playing you:

wget http://security.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.79.6_all.deb
--2013-09-24 09:39:08--  http://security.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.79.6_all.deb
Resolving localhost (localhost)... ::1, ::1,
Connecting to localhost (localhost)|::1|:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: 23217718 (22M) [application/x-debian-package]
Saving to: ‘linux-firmware_1.79.6_all.deb’

100%[======================================>] 23,217,718   153KB/s   in 3m 3s  

2013-09-24 09:42:10 (124 KB/s) - ‘linux-firmware_1.79.6_all.deb’ saved [23217718/23217718]

Only, don't use the proxy and everything should be fine. wget --no-cache or deleting all your proxy cache should do the job.

  • I'm sure you're right. But it seems that the cached had cleared itself since I last tried, as the download Just Worked. My upgrade is now in progress. Thanks.
    – Dave Cross
    Sep 24, 2013 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.