I downloaded Virtual Box and installed it. I followed instructions on how to set it up but when I went to run it I got the following errors on the right side of the image below ↓

enter image description here

I tried the sudo apt-get install virtualbox-qt advise from here: → There is an error when I try to install virtual box into Ubuntu and got the following read out:

Reading package lists... Done Building dependency tree
Reading state information... Done virtualbox-qt is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I also tried the: /etc/init.d/vboxdrv setup advise in the top error report and got this read out: "bash: /etc/init.d/vboxdrv: No such file or directory"

Can someone instruct me on what I should do to fix this problem?

"EDIT" ↓

After a complete new install of Ubuntu 12.04 this morning, I followed NikTh's advise and downloaded Oracle’s Virtual Box V-4.2 from the link he provided. Set it up and tried to run it. I did not have an ISO (lost in the computer crash last night) so I booted it from CD/DVD drive, with the same Live CD I used to re-install this morning... This is the problem I have now, (above the cursor). ↓

enter image description here

Can someone please explain why Ubuntu 12.04 will run on my laptop but not on my Virtual Machine? Am I missing some settings somewhere?


I finally got Ubuntu 13.04 32 bit, to run in my Virtual Machine, so it is working properly...

My Final question is this - If Ubuntu 12.04 64 bit version runs on my laptop how come it does not run in my VM?

Thank you, "NikTh" & "Terry Wang" for your patience and all your help...

  • 1
    Did you reboot ? Reboot and if you still have problems, try to execute the command again (root privileges needed) sudo /etc/init.d/vboxdrv setup
    – NickTux
    Sep 18, 2013 at 22:57
  • 1
    Does /etc/inti.d/vboxdrv actually exist? It is a shell script.
    – Terry Wang
    Sep 18, 2013 at 23:01
  • @NikTh I did what you suggested and rebooted, had the exact same result as before. I also did sudo /etc/init.d/vboxdrv setup and got the same result also... Thank you for trying though... Sep 19, 2013 at 2:49
  • What version of virtuabox have you installed ? Are you sure that you don't have installed and mixed up the two versions ? I mean the Oracle's version with OSE version ? Lets try these commands now and see sudo apt-get update and sudo apt-get install dkms and sudo /etc/init.d/vboxdrv setup if the result is the same, try sudo /etc/init.d/virtualbox-ose start
    – NickTux
    Sep 19, 2013 at 2:58
  • On the last one only? what about sudo /etc/init.d/vboxdrv setup ? What this returned ?
    – NickTux
    Sep 19, 2013 at 9:58

2 Answers 2


The last updated image "This kernel requires x86_64 CPU but only detected an i686 CPU" indicats that you are trying to run a 64-bit Linux guest but your host does NOT support VT-x or AMD-V.

Please run this command to make sure your CPU is capable of Intel VT-X or AMD-V

egrep -wo '(vmx|svm)' /proc/cpuinfo

Example on a Core i5 CPU

$ egrep -wo '(vmx|svm)' /proc/cpuinfo

Make sure 2 things

  • VT-x or AMD-V is enabled in HOST BIOS
  • In the VM settings - System Acceleration - tick Enable VT-x / AMD-V
  • I checked everything you said. The System Acceleration Tab was darkened and I could not open it. As far as the commands you gave, I ran them and got nothing... All this did make me remember that I accidentally (forgetting to get the 64 bit version) downloaded Ubuntu 13.04 32 bit. I tried the Virtual Box with that Live CD and everything worked just fine... Thanks for the help Terry... Sep 20, 2013 at 0:49

This error occurs everytime you upgrade your Host machine's Kernel.

As the error states run "sudo /etc/init.d/vboxdrv setup" from a terminal session and you can then start your Virtual machine from there.

As I mentioned you will need to do this after each kernel upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.