My Intellij version is 12.1 and new version is 12.1.4 so I want to update it but after dowloading new file it can not proceed because of file permission denied. Can any one tell me how to change permission so I can update my Intellij?

  • are you trying the update as root? – sosytee Sep 18 '13 at 5:34
  • No I didn't. I just click "update and restart" button as the Intellij start and can not proceed. – Hà Link Sep 18 '13 at 10:05
  • please see youtrack.jetbrains.com/issue/IDEA-23308. Try changing the owner of Idea installation directory from root to user(you) – lena Sep 18 '13 at 14:31

Go to the /bin Folder of the "Idea", for Example (or in my case):


and there start the App, with sudo. Like this:

sudo ./idea.sh

Just update,

if you have any /tmp memory space problem, restart your OS and try the step again.

Hope this help you.

  • Just noting that it took me a few restarts as sudo to get the update button to show. In the end, it worked! – jemiloii Aug 24 '15 at 14:47
  • Great, I think you can change the folder(/idea-IC-135.690/bin) permission also, to don't have to open idea with sudo. – Aby Aug 25 '15 at 8:36
  • 1
    I didn't think of that, I just gave idea.sh 777 permissions since this is my dev machine. – jemiloii Aug 25 '15 at 15:27
  • 1
    On my machine (OS X), it was cd /Applications/Intellij IDEA 14/Contents/Mac OS then sudo ./idea. – Max Heiber Dec 2 '15 at 14:54
  • I get: "Startup Error: Unable to detect graphics environment" Any idea how to fix that? – Didier A. Dec 28 '17 at 20:35

Had the same issue with Idea IntelliJ 2016.2

You should set the user and group of your idea folder to yourself. (or a group that you share with other users, if you need)

In my case, it was because some files in idea were assigned to root:root, and I didn't see the point.

So I ran: sudo chown -R jcharlet:jcharlet /opt/idea-IC-162.1121.32

  • 2
    I think this is a better solution than the previous one ;) – Carlos Verdes Mar 23 '17 at 5:28
  • This solution will solve the issue every time without the need to restart with root. Much better solution. – borjab Jan 23 '18 at 11:18
  • This should be the accepted answer. I was unable to update IntelliJ Idea. Assigning permissions to my user solved it for me. – Thilak Rao Mar 27 '19 at 9:49

The solution Jeremy provided is the best one on my opinion. What I would recommend is to use whoami utility call to set parameters of the current console user automatically like

sudo chown -R $(whoami) /opt/idea-ICblablabla

  • 3
    The cleanest solution from my point of view. – jpmottin Mar 18 '18 at 15:45
  • 1
    The best solution, works out of the box and fixes the problem for good. – Alan47 Feb 1 '19 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.