This question already has an answer here:

So I had a full /boot and I've really messed things up now. What I'd really like to do is run sudo apt-get purge linux-image-3.2.0-{35,36,37,38} but I need to fix these other problems first. So when I run sudo apt-get -f install this is what I get (I also get similar output for any other apt-get commands)

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 192 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,726 B of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? 
dpkg: dependency problems prevent configuration of linux-generic-pae:
 linux-generic-pae depends on linux-image-generic-pae (=; however:
  Version of linux-image-generic-pae on system is
 linux-generic-pae depends on linux-headers-generic-pae (=; however:
  Version of linux-headers-generic-pae on system is
dpkg: error processing linux-generic-pae (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                       Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

But this doesn't tell me enough what the other error was. I think it started when I ran sudo apt-get -f install with only about 20MB of free space in /boot. Grrr, /boot partition is super annoying.

marked as duplicate by Braiam, Kevin Bowen, Luis Alvarado Sep 24 '13 at 3:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


why don't you use Debian package management system - dpkg?

Simply remove old kernels with this commands:

# dpkg -P linux-image-3.2.0-{35,36,37,38}* 

Okay found the solution here: https://askubuntu.com/a/183625/7945

I needed to edit /var/lib/dpkg/status manually and remove the linux-generic-pae package, then I was able to run my purge command and then I was able to reinstall linux-generic-pae. I did sudo apt-get install --reinstall linux-generic-pae just to be sure.

Not the answer you're looking for? Browse other questions tagged or ask your own question.