I tried following the instructions here: http://lani78.wordpress.com/2008/08/08/generate-a-ssh-key-and-disable-password-authentication-on-ubuntu-server/

to only allow users with a public key on the server to authenticate, but I can't get SSH to disallow logging in with only a username/password.

Here is my sshd_config file - am I missing anything? I already tried restarting SSH and the computer itself.

# Package generated configuration file
# See the sshd_config(5) manpage for details


# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes


# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768


# Logging
SyslogFacility AUTH
LogLevel INFO


# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes


RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile        %h/.ssh/authorized_keys


# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes


# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no


# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no


# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication no


# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes


# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes


X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no


#MaxStartups 10:30:60
#Banner /etc/issue.net


# Allow client to pass locale environment variables
AcceptEnv LANG LC_*


Subsystem sftp /usr/lib/openssh/sftp-server


# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM no
  • 1
    FYI : Actually the sshd restart is not really necessary. The command /etc/inid.d/ssh reload should be enough. – Oliv Feb 24 '16 at 22:23

By default PasswordAuthentication is set to yes, even if you comment it out. That's the case in your /etc/ssh/sshd_config.

You need to explicitly set PasswordAuthentication no to allow only Public Key Authentication.

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

And restart sshd service ssh restart (pre systemd migration) or systemctl restart sshd.service.

  • 5
    Also we should have UsePAM no – Konstantinos Apr 7 '15 at 21:22
  • @pidosaurus why? what is it good for? – jan-glx Dec 11 '15 at 11:56
  • 1
    @YAK I like to keep things simple and I prefer not to use PAM. But somebody can use a properly configured PAM authentication. I think this link is enlightening: arlimus.github.io/articles/usepam – Konstantinos Dec 15 '15 at 14:00
  • Consider also disabling ChallengeResponseAuthentication, see superuser.com/a/374234/2879. – cic Jul 6 '16 at 17:36
  • service ssh restart will work fine on systemd-based Ubuntu. It's a wrapper that will call systemctl as needed. (Of course, if the name of the service is sshd, then it's service sshd restart, but it's not.) – muru Oct 10 '17 at 5:08

According to this wiki page about SSH keys and this answer, you need to change these two lines in your sshd_config:

PasswordAuthentication no
ChallengeResponseAuthentication no
  • What difference does the second line about challenge response make? – Ryan Burnette Jul 21 '16 at 19:17
  • 1
    "It doesn't provide "additional security," per se. The term "ChallengeResponseAuthentication" is just an OpenSSH configuration keyword; it refers to the "keyboard-interactive" userauth method in the SSH protocol —Richard Silverman (fixunix.com) – pzkpfw May 22 '17 at 9:23

In /etc/ssh/sshd_config, below settings worked for me:

PasswordAuthentication no
UsePAM no

Finally, restart sshd daemon.

The line you want is abnormally commented out by default in the sshd_config file.

# Change to no to disable tunnelled clear text passwords
--->#PasswordAuthentication yes

To disable passwords, change the yes to no and remove the comment:

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

from https://www.ssh.com/ssh/copy-id#sec-How-ssh-copy-id-works: Generally, the user's home directory or any file or directory containing keys files should not be writable by anyone else. Otherwise someone else could add new authorized keys for the user and gain access. Private key files should not be readable by anyone else.

Try with sudo chmod go-rwx /home/username/ replacing username as appropriate.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.