So I want to start using Launchpad to push some packages. I use GitHub to upload my code to, and I have noticed that there is an option to upload/import from a Git repository (that is what I did). It worked fine. However, when I tried to build the packages they fail with the following error:

Building recipe:
# bzr-builder format 0.3 deb-version bugzilla4-{time}

You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data.  See "bzr help launchpad-login".

I am not sure what I should do.

Possible problem:

  1. The recipe I wrote does not work
  2. I need to use bzr instead of git
  3. other

Please tell me what is the problem and how do I solve it?

One of the many logs can be seen here.

1 Answer 1


The You have not informed bzr... message is just noise (it's occurring because the buildds connect over http), and is irrelevant. Your actual problem is this:

bzr: ERROR: No previous changelog to take the package name from, and --package not specified: debian/changelog was not present.
RUN: /usr/share/launchpad-buildd/slavebin/scan-for-processes ['/usr/share/launchpad-buildd/slavebin/scan-for-processes', 'd32285173fe3adb998c9dc6e2664f76ffd961367']

You need to merge in a packaging branch that contains an appropriate debian directory including a debian/changelog. If the thing you're packaging is already in Ubuntu you can often just merge from that, but as bugzilla4 does not seem to be in Ubuntu yet, you will probably need to create a new packaging branch. It will probably be easier if you do that in Launchpad in Bazaar so that it can eventually become the main packaging branch, and you might be able to start from the lp:ubuntu/bugzilla branch, depending how much they've changed from 3 to 4.

  • First, I like how you knew that the project I was doing is Bugzilla ;). Second, I actually checkout their code and modified it to work for Bugzilla 4. However, I am not completely sure whether my updates work or not, since the branch is not updating.
    – Tamer
    Apr 20, 2011 at 13:27
  • The name 'bugzilla' is in your original question ;-) But, anyhow, if you do not either have a debian directory in the upstream branch, or have one in a packaging branch you're merging in, this isn't going to work.
    – poolie
    Apr 20, 2011 at 23:54
  • I noticed! I got that fixed but I cannot understand why is it not building now, I don't even understand why is it not compiling. Log at launchpadlibrarian.net/70101359/…
    – Tamer
    Apr 21, 2011 at 12:36
  • Well, the problem now is that the patches are failing to apply. I guess this means that you are merging in a packaging branch that holds patches that no longer make sense against bugzilla4.
    – poolie
    Apr 21, 2011 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.