4

Before extracting an ISO image onto a USB device using Startup Disk Creator, when I try to erase the USB device using the same software, I always get the following error:

Startup disk creator error

I have tried to erase various USB devices without success, so I believe this is not a device-specific problem. I see that a bug on this has been filed on launchpad, though an alternative/solution/word-around has not been suggested.

Is there a way to solve this error, without using other softwares to erase disk?

System specifications:

  • Ubuntu 12.10
  • Startup Disk Creator 0.2.4
5

Try this. Insert your USB flash drive, and just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

dmesg | tail

enter image description here

The sdb is your USB drive, yous might be different

Unmount your USB drive using the following command:

sudo umount /dev/sdx

Format the drive using the following command: (this would format it as FAT32)

sudo mkdosfs -F 32 -n 'Label' -I /dev/sdx

make sure that you replace the x with your device id.

  • I would appreciate a solution to this problem, not an alternative :) Though this should work. – jobin Sep 17 '13 at 16:45
  • OK, I can respect that. Try this on on of the USB drives sudo fsck -a. – Mitch Sep 17 '13 at 16:49
  • The device I am working on is a FAT device, the output of dosfsck is here: pastebin.ubuntu.com/6120192, though the error remains. – jobin Sep 17 '13 at 17:00
  • OK. Try formatting as FAT 32, and then try Startup Disk Creator again. – Mitch Sep 17 '13 at 17:30
  • The error remains the same, @Mitch! – jobin Sep 17 '13 at 17:38
2

This is what worked for me:

  1. If you have Startup Disk Creator, Disk Utility, or GParted open, close them
  2. Safely remove your USB flash drive and reinsert it
  3. If it isn't already installed, install GParted through the Software Center or:

    sudo apt-get -y install gparted
    
  4. Open GParted (in Xubuntu/Xfce it's in Settings) and select the USB drive from the dropdown near the top right

  5. If there are any partitions on the drive, right-click them → Unmount
  6. DeviceCreate Partition TableSelect new partition table typemsdosApply
  7. PartitionNewFile systemfat32Add
  8. Click the green check icon near the top to apply the changes → Apply
  9. When it's done, close GParted, open Startup Disk Creator, and proceed as usual

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.