I am using my Rasberry Pi as a print server using Samba. I have followed this tutorial, but i cannot print from my ubuntu laptop. I have added it as Windows Printer via Samba. But i get the NT_STATUS_ACCESS_DENIED error when i try to print. If i add credentials when i add the printer (i use my raspberry pi username and password (which should be added to the right group)) i get: "Not authorized, The password may be incorrect."

I know i could just as well post this in a raspberry pi forum, but since the problem is only with Linux/Ubuntu i thought i would post it here...

  • Seems to be in the Samba Configuration. Can you verify if your Samba printer share looks like this? sudo nano /etc/samba/smb.conf [printers] comment = All Printers browseable = yes path = /tmp printable = yes public = no writable = no create mode = 0700 You may want to take a look at this as well: mardou.dyndns.org/Privat/raspberry.nsf/id/JUND-95VRCY – Arnold Sep 17 '13 at 19:35
  • If i change it to what you write i cant even browse it. I can add it directly if i put the ip in, but i still get the same error as above... Im confused. I think its strange that it doesn't work in Ubuntu when it works in Windows... – dhojgaard Sep 17 '13 at 20:03

The answer for me were to put the following in the smb.conf on the raspberry pi:

use client driver = yes
  • Oh yeah right. That generally applies on almost every samba printer share. I forget about this. – Arnold Sep 20 '13 at 18:24
  • apparently there is nothing like this by default in the smb.conf. Not even uncommented. – dhojgaard Sep 21 '13 at 16:49
  • I agree, it took me hours googling as I remember. It was years back though when I had a cups server serving windows users. – Arnold Sep 25 '13 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.