I created an alias to turn the mousepad off with synclient, but it does not respond as expected. After running the synclient touchpadoff=1 in the terminal however, the alias starts to work properly.

The alias to start and stop xampp work fine every time.

From ~/.bashrc:

# Custom aliases

alias lamp="sudo /opt/lampp/xampp start"  
alias stoplamp="sudo /opt/lampp/xampp stop"  
alias touchoff="synclient touchpadoff=1" 
alias touchon="synclient touchpadoff=0"

Can anyone see why this is?


I moved the aliases to .bash_aliases and placed touchoff and touchon first. This seems to alter the results abit. Now it works when I run the command touchoff twice. And when I run touchon again (once), the touchpad works for a few seconds. When I run it again, it sticks.

I have also tested this on Fedora 18 where the .bashrc file is almost empty, and it works as expected. No issues there.

If someone else could try this in Ubuntu 13.04 and leave a comment below, that might be helpful. It requires a reboot, though. Sorry for asking... -_-


Your problem is not with the alias. The fault is because of this synclient command and I faced the same problem:

synclient bug

Now, I just confirmed this bug on Launchpad: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/673875.

As alternative you can use xinput:

  1. Determine the device id (the device name should be something with "touchpad" or "glidepoint"):

    xinput list
  2. Alias to disable it (e.g. here the device id is 14):

    alias touchoff='xinput disable 14'
  3. Alias to enable it:

    alias touchon='xinput enable 14'

Source: https://help.ubuntu.com/community/SynapticsTouchpad


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.