As of today, TMDB dropped support for their version 2.1 api, which is where (mythvideo, at least) is grabbing their data.

How do we set the Ubuntu version of mythtv (0.25) up to use the version 3 api, which is still supported?

I tried replacing tmdb.py with tmdb3.py, and this seems to have helped some, but it seems to crash when more than one possible match is encountered. Also, I'm not sure if something needs to be done for tvdb searches as well, as I don't currently have any Mythvideo TV shows that are missing metadata.

Any help that could be provided would be greatly appreciated.

  • How did you install tmdb3.py, and where did you get it from? I saw this version, but haven't tried it yet. I'm trying to solve the same problem myself. – Calrion Sep 23 '13 at 2:46
  • It do not funcion for me. I have just installed fresh mythbuntu, updated .25 version, dowloaded tmdb3.py copy to tmdb.py - no cooperation between mythbuntu and tmdb3 script I can run tmdb.py and I receive results but something is wrong with cooperation. Any suggestion? – user260213 Mar 20 '14 at 12:03

You can get it to work:

After this, I was able to look up movie information by title and by entering the TMDB number.

Television updates still work fine.

| improve this answer | |

My 12.04 Mythbuntu installation had a tmdb3.py already under /usr/share/mythtv/metadata. However, it appears to be an earlier version of the script and I don't know if it's accessing V3 of the api.

Using the one from github works for me.

| improve this answer | |
  • Welcome to Ask Ubuntu. It would be nice if you would complete your answer adding from where on github you found a new version. – MadMike Nov 18 '13 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.