0

I have installed Ubuntu Server 12.04 x64 on an HP Proliant DL380 G7 (dual CPUs, 24GB RAM, RAID 5 - 300GB). Clean install, nothing else is on the machine. Virtualizing this machine isn't an option or I would already have done that.

I am trying to bond the network connections of the built in 4-port Broadcom NIC with an HP 331T adapter (Broadcom). Both are gigabit and are recognized by Ubuntu (latest firmware has been applied to everything).

I am trying to create two bonds (bond0 and bond1), corresponding to the front-end and back-end network. Each bond has a single connection to each NIC.

I have done an extensive amount of troubleshooting/reading over the past 2 days and have had a little bit of success, but I have run into issues at every step. Most of what I read out there deals with creating a single bond between multiple interfaces. There is virtually no information on creating multiple bonds over multiple interfaces. I am looking for anyone's help/input. It would be greatly appreciated! I figure someone out there has done this in Ubuntu before.

As it stands right now, I have both bonds mostly working. If I only wanted a single bond, I would have no problems. The second bond is where the problems start.

  • The server hangs at boot trying to start bond1 (which is the 2nd bond). After around 5 minutes, the server finally boots and everything works fine (including bond1)
  • Restarting the networking service causes bond1 to become unresponsive. I have to restart the entire machine to get bond1 back. Trying ifup bond1 results in various issues like bond1 is already configured/is already up.

I have also tried sudo networking service stop && sudo networking service start, same issue.

Config Files: (have tried virtually every combination of parameters- the following is what got me the furthest)

/etc/modprobe.d/bonding.conf:

alias bond0 bonding options bond0 mode=4 lacp_rate=1 miimon=100 max_bonds=2
alias bond1 bonding options bond1 mode=4 lacp_rate=1 miimon=100 max_bonds=2

/etc/network/interfaces (no gateway needed on bond1 - backend):

auto eth3
iface eth3 inet manual
bond-master bond0

auto eth4
iface eth4 inet manual
bond-master bond0

auto bond0
iface bond0 inet static
address 10.100.0.60
netmask 255.255.255.0
gateway 10.100.0.1
dns-nameservers 10.100.0.53 10.100.0.54
post-up ifenslave bond0 eth3 eth4
pre-down ifenslave -d bond0 eth3 eth4

auto eth0
iface eth0 inet manual
bond-master bond1

auto eth1
iface eth1 inet manual
bond-master bond1

auto bond1
iface bond1 inet static
address X.X.X.X
netmask 255.255.255.0
post-up ifenslave bond1 eth0 eth1
pre-down ifenslave -d bond1 eth0 eth1

/etc/modules:

loop
lp
rtc
bonding
0

have you tried to verify exit code of the ifenslave of the post-up ?. Documentation says that ifup would fail if exit code is diff from 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.