Whenever I start my laptop the process tracker-store and tracker-miner-fs eats up my CPU between 30-40% for 10-15 minutes. I am on ubuntu 12.04.

What does these processes do? How to get rid of processes?

  • Is all the software on your system from the software center or have you installed software from elsewhere? Can you connect tracker-x to anything? FWIW, I don't see a process called tracker-x with Lubuntu 13.04. If you have no "privacy concerns" you could post the output of something like ps -e and dpkg --get-selections here or @ pastebin. Maybe someone could figure out what's happening.
    – user25656
    Sep 16, 2013 at 12:21
  • 7
    I have just experienced something similar on Ubuntu 16.04.1 LTS.
    – Alexey
    Sep 15, 2016 at 18:39
  • 4
    Ubuntu 20.04 and Ubuntu 19.10 have the same issue: High cpu load for a long duration caused by tracker, tracker-miner and tracker crawler. Since searching HDs is the main task it slows down the computer from two sides: HD + CPU load. Bad design. What is this tremendous amout of data used for? No kernel will ever need that! Is it eventually used as a spy tool? What a terrible design: There is an option not to run tracker on battery power: Not used. Fortunately you can disable tracker in dconf-settings, see post abouy using dconf-editor org > freedesktop > Tracker > Miner > File " Apr 17, 2020 at 20:29
  • 3
    check this out unix.stackexchange.com/questions/482390/… worked for me flawlessly .. I migrated from 18.04 to 20.04 and nothing worked properly... this did the trick
    – Mr.P
    Apr 22, 2020 at 11:00
  • 2
    With Ubuntu 20.04 this problem came up again. You really can purge it since it does not even find all files properly.
    – user8842
    Nov 16, 2020 at 8:17

9 Answers 9


Scripting solution to disable it permanently on Ubuntu 16.04

As mention in the comments, files mention in this post no longer exist in 16.04. You can use the following script (source):

echo -e "\nHidden=true\n" | sudo tee --append /etc/xdg/autostart/tracker-extract.desktop /etc/xdg/autostart/tracker-miner-apps.desktop /etc/xdg/autostart/tracker-miner-fs.desktop /etc/xdg/autostart/tracker-miner-user-guides.desktop /etc/xdg/autostart/tracker-store.desktop > /dev/null

# Interval in days to check whether the filesystem is up to date in the database. 0 forces crawling anytime, -1 forces it only after unclean shutdowns, and -2 disables it entirely
gsettings set org.freedesktop.Tracker.Miner.Files crawling-interval -2  # Default: -1
# Set to false to completely disable any file monitoring
gsettings set org.freedesktop.Tracker.Miner.Files enable-monitors false # Default: true

Cleanup the database with:

tracker3 reset --filesystem --rss  # Tracker v3+

# Or, for older versions
tracker reset --hard  # 

These are confirmed bugs on Launchpad: 911981, 925948, 1063255.

What does these processes do?

Tracker is a synergy of technologies that are designed to provide a highly sophisticated, innovative and integrated desktop.

Tracker provides the following:

  • Indexer for desktop search (for more details see this spec : https://wiki.ubuntu.com/IntegratedDesktopSearch)
  • Tag database for doing keyword tagging of any object
  • Extensible metadata database for apps like gedit and rhythmbox which need to add custom metadata to files
  • Database for first class objects allows using tracker's database for storage and implementation of First Class Objects and the Gnome 3.0 Model.

How to get rid of processes?

  1. Disabling tracker for globally (for all users)

  2. Edit /etc/xdg/autostart/trackerd.desktop file with root privileges (sudo -i gedit /etc/xdg/autostart/trackerd.desktop)

  3. Add Hidden=true to the end of the file

  4. Do the same for /etc/xdg/autostart/tracker-applet.desktop if you want

  5. Disabling tracker for your user only

  6. Enter the directory ~/.config/autostart, create it if it does not exist

  7. Create a file named trackerd.desktop

  8. Paste the following into the file, save and exit:

    [Desktop Entry]

Source: https://wiki.ubuntu.com/Tracker

  • 10
    @codingcrow Don't uninstall it, and don't even think of a purge. A disable would be enough. :-)
    – TomKat
    Sep 22, 2013 at 13:51
  • 10
    @TomKat: Why not? I just did apt-get uninstall tracker on gnome-ubuntu and it worked fine.. it also removed gnome-documents, but whatever, didn't even know I had that program :)
    – benjaoming
    Nov 21, 2013 at 23:49
  • 6
    This doesn't work. Miner still runs on every boot. Oct 17, 2014 at 23:36
  • 4
    will disabling this process affect search performance ?
    – Nasreddine
    Mar 24, 2016 at 7:02
  • 25
    I'm still wondering which genius decided to create an enormously CPU- and RAM-hungry program that loads itself on startup, and have it the words "tracker" and "miner" right in its name... Jul 28, 2021 at 13:31

Simply change this values using the gsettings witch will disable the constant indexing of Tracker:

gsettings set org.freedesktop.Tracker.Miner.Files crawling-interval -2  
gsettings set org.freedesktop.Tracker.Miner.Files enable-monitors false

The values could be changed using dconf-editor by navigating through org > freedesktop > Tracker > Miner > Files:


After this changes, it is highly recommended to cleanup the database to reclaim some lost space on the disk:

echo y | LANG=en tracker reset --hard
  • 2
    Thank you very much, I just had to run tracker-control-r and all sorted ...
    – JoZ3
    Nov 2, 2013 at 13:22
  • 1
    What exactly does tracker-control -r do? It sounds like since this post tracker-control has been deprecated and it's migrated to the tracker daemon command, but tracker help daemon (or tracker-control --help) doesn't mention a -r flag. Does it still do the same thing? I can't find the old documentation.
    – redbmk
    Apr 6, 2016 at 10:16
  • 5
    I believe the modern equivalent is tracker reset --hard.
    – jcupitt
    Sep 10, 2016 at 12:26
  • 1
    Following this step, after run tracker-control -r my laptop went back to smooth again! PS: tracker-control is not available anymore in 16.04, but relax, it will trigger the substitute command which is tracker daemon.
    – adadion
    Nov 24, 2016 at 7:51
  • tracker-control: command not found Why is that?
    – Tooniis
    Feb 24, 2018 at 10:28

Maybe it's relevant for Ubuntu 14.04/GDM, and if it important to do not remove whole service then will be better to stop and/or renice.

Hence it can be:

Stop/reniced ( not recommended method ):

$ tracker-control -p  
Found 171 PIDs…  
Found process ID NNNN for 'tracker-store'  
Found process ID MMMM for 'tracker-miner-fs'  

$ initctl stop tracker-store && renice -n +19 -p NNNN && initctl start tracker-store

Notice people suggest yet tracker-control -r and maybe for systems with indexing enabled this will be better:

$ tracker-control -e

OR the same with System Monitor GUI:

Applications > Utilities > System Monitor

  • sort > Name
  • scroll > tracker-store
  • right click > Stop Process
  • right click > Change Priority > Very Low
  • right click > Continue Process

OR maybe the most appropriate way for systems with running tracker-store:

Applications > System Tools > Search & Indexing

List item

  • 1
    Thank you! I hadn't noticed the option to force tracker to be used only when the computer is not being used. Let's see if that does the trick. Sep 30, 2015 at 6:20
  • 1
    this worked for me. i unchecked all locations, and limited other options to their most minimal settings, the "re-indexed", and it stopped. i like this route, as it is something i will likely remember what i did. Apr 7, 2016 at 17:13
  • 4
    For ubuntu users, sudo apt-get install tracker-gui
    – smac89
    Jun 15, 2016 at 21:44
  • 1
    The tracker-gui program is the only option that didn't feel like a total hack for me. +1
    – grooveplex
    Nov 6, 2016 at 13:25

An up to date version for Ubuntu 16.04:

echo -e "\nHidden=true\n"|sudo tee --append /etc/xdg/autostart/tracker-extract.desktop
echo -e "\nHidden=true\n"|sudo tee --append /etc/xdg/autostart/tracker-miner-apps.desktop
echo -e "\nHidden=true\n"|sudo tee --append /etc/xdg/autostart/tracker-miner-fs.desktop
echo -e "\nHidden=true\n"|sudo tee --append /etc/xdg/autostart/tracker-miner-user-guides.desktop
echo -e "\nHidden=true\n"|sudo tee --append /etc/xdg/autostart/tracker-store.desktop

gsettings set org.freedesktop.Tracker.Miner.Files crawling-interval -2
gsettings set org.freedesktop.Tracker.Miner.Files enable-monitors false

tracker reset --hard

Basically this is a remix of Radu's and Maxwell's answers, but locations and commands have been updated to Ubuntu 16.04 (there were multiple changes).

  • When adding these lines one by one in terminal, it gives this timeout warnning for each command.echo -e "\nHidden=true\n"|sudo tee --append /etc/xdg/autostart/tracker-extract.desktop sudo: unable to resolve host Thusitha: Connection timed out Oct 5, 2016 at 8:37
  • 1
    this also seems to work well for debian buster
    – MrMesees
    Apr 26, 2020 at 7:44

I simply disabled it in Ubuntu Settings -> Search. In the top bar, there is a toggle for on/off of whole search. I set it to off and then ran:

tracker reset --hard

After this it looks like no tracker process is running anymore.

  • 1
    There is no indication that Settings->Search has something to do with tracker. Search is not documented by gnome so it is hard to tell. If you are right this is the absolute top answer. Mar 2, 2021 at 0:08
  • 3
    In Ubuntu 22 the command is tracker3 reset -r
    – xinthose
    Jun 15, 2022 at 18:43
  • 1
    I followed these instructions (on 22.04), logged out, and logged back in again and tracker started indexing my files again. Seems like turning off the search toggle in settings just changes the Activities Overview search behavior, not the actual indexing.
    – David
    Oct 28, 2023 at 17:12

Enable advanced Startup Applications with this command:

sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" /etc/xdg/autostart/*.desktop

Run Startup Applications and uncheck Tracker File System Miner and the other similar items. They can be re-enabled just as easily.


Using Synaptic, I selected "mark for complete removal" for "tracker", and for "zeitgeist" (kin to using the purge command which is supposed to remove associated components and config files for the program selected). Much more of the zeitgeist tracking software had been installed unknown to me, and so I chose complete removal for all except the zeitgeist shared libraries which looks to be way too embedded in the OS to remove safely. Almost like a dog with a bad case of heart worms, or better yet like a hydra. Chop one head off and there's three more trying to ruin your chi. Sounds pretty much like something microsoft enjoys doing to the people who trust them. Whatever... My laptop now boots in less than half the time, doesn't completely bogg down at random occasionally crashing what I'm using at the time, and it might just be the relief of getting rid of the thing but the rest of the software seems to be running much better without that hydra's heavy tentacles. Aww ferget it... You know what I mean.

Why is it that programs like these have to be brought in quietly through a back door? Perhaps it's because nobody wants that sort of thing on their personal laptop. If I was a tech running server edition on a mainframe that had massive gigs of ram and cores out the wahzoo, then it would be another story. Perhaps then I would like to utilize tracking software. Even then, I would still want it to be an application of my choosing.

Just saying.

  • Since I use none of featues provided by tracker, I'll go with "complete removal". The day I'll need something like this, I'm sure I'll re-install
    – Augusto
    May 1, 2015 at 5:33

Answers above didn't help me. I've finally found a solution:

Running miner with high verbosity:

/usr/libexec/tracker-miner-fs -v 3

allowed me to pinpoint what's wrong - it was a directory with a very large number of files (around 1 million - proceduraly generated as a side effect of some project). Removing this mess fixed the issue.

  • Very nice ;-) You could have a legitimate reason to have a directory with that much itims. So you should file a bug report instead of complimenting tracker. Mar 1, 2021 at 23:58
  • 1
    @AlbertvanderHorst I'm new to this. How would I go about submitting it as a bug?
    – Radost
    Mar 2, 2021 at 13:08

One solution is to get rid of it altogether, and go old-skool find(1) if you want to search.

$ sudo apt remove tracker tracker-extract tracker-miner-fs

Personally, I removed it because I was getting this in my logs:

SQLite error: database disk image is malformed (errno: Resource temporarily unavailable)

Caveat Emptor: As a side-effect, I noticed that nautilus somehow got uninstalled with this. Not sure how.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .