2

If I try and boot without nomodeset I go to a black screen. On this I can adjust my brightness using Fn + <-/-> but I can't actually do anything.

I can boot with nomodeset but then I cannot change brightness. I have tried boot options like acpi_osi=Linux and acpi_backlight=vendor which have no effect.

I've seen some recommendations to edit /sys/class/backlight/acpi_video0/brightness, but my /sys/class/backlight directory is empty.

I'm guessing there's a problem with my video drivers (I have Intel HD 4000)?

The output of lspci -nnk | grep -A5 VGA is as follows

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

Subsystem: Acer Incorporated [ALI] Device [1025:0799]

00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family>USB xHCI Host Controller [8086:1e31] (rev 04)

Subsystem: Acer Incorporated [ALI] Device [1025:0799]

Kernel driver in use: xhci_hcd

00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)

  • From where did you change the options acpi_osi=Linux and acpi_backlight=vendor? From /etc/default/grub? It should work.. – Saurav Kumar Sep 14 '13 at 21:10
  • Could you add the output of lspci -nnk | grep -A5 VGA? – Braiam Sep 14 '13 at 21:26
  • Saurav: I edited /etc/default/grub, in particular the GRUB_CMDLINE_LINUX_DEFAULT= line reads quiet splash nomodeset acpi_osi=Linux acpi_backlight=vendor. – Adrian Sep 14 '13 at 21:37
  • @Adrian did you get the solution for this? I have MSI GE62 facing same problem. – Chaitanya Chandurkar Dec 31 '15 at 1:16
1

Although it's like a brute force method it worked for me. Initially, when my Ubuntu was stuck at the purple screen:

  1. I restarted the system.
  2. Pressed E key and added nomodeset as: ro quiet splash &vt_handoff nomodeset.
  3. Pressed F10 and once the system restarts , open terminal.
  4. Write sudo gedit /etc/default/grub/ in the terminal.
  5. Add nomodeset like this, GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
  6. Save the file and write sudo update-grub.

Now the main part:

  1. Go to applications and open software and update.
  2. Click additional drivers and choose the recommended one and NOT X.Org xserver.
  3. Once Done with this, restart the system.
  4. But this time again press E on grub menu and (remove) nomodeset and press F10.
  5. The system will start normally.
  6. Once started, open the grub file again as in step 4, but this time remove nomodeset and save the file.
  7. Write sudo update-grub and restart the system.

Congratulations! Now your system will work perfectly with normal boot, without nomodeset and you would be able to inc/dec the screen brightness.

0

I had a similar problem and wrote scripts to compensate for the loss of backlight control with nomodeset. If this is still a thing you could try out the intelBrightness file from https://github.com/vjay82/Linux-i915-Backlight-Control

  • 1
    Please include the essential part of the solution – Mostafa Ahangarha May 18 '16 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.