10

I'm having a hard time building a VIM 7.4(obtained from vim's ftp site) with gui option. It builds ok without the gui
option. Here's how I'm doing it:

cd ~/Downloads/vim74/src
./configure --enable-gui

The above line does not seem to work because I get this output from the command:

./configure --enable-gui | grep gui
checking --enable-gui argument... no GUI support

I uncommented line 352 of the makefile to enable the gui(I think):

CONF_OPT_GUI = --enable-gui=gtk2

But when I run vim -g(after rebuilding) I get:

E25: GUI cannot be used: Not enabled at compile time

There's a suggestion in the makefile to check the generated auto/config.h and
auto/config.mk files but the files are empty(less than 10 lines).
How do you fix this?

8
  • possible duplicate of How can I build vim with a gui without gtk? Sep 14, 2013 at 20:07
  • @RaduRădeanu I'm not looking for the appropriate apt command, it would probably work(haven't tried it). I want a solution for when compiling from its sources.
    – Plakhoy
    Sep 14, 2013 at 20:30
  • Ok, I will retract the close vote, but I will let the comment for future users. Sep 14, 2013 at 20:39
  • Did you do a make install or just a make? if the latter, then in order to run the newly-built binary you must specify the path explicitly i.e. if you are in the vim74 directory where you issued the make command, do ./src/vim -g . It should not be necessary to specify any additional options to configure, I just tested it and the default configuration produced a GUI-enabled executable. Sep 14, 2013 at 21:40
  • @steeldriver, I've tried both with no luck. Mine does not even generate the ./src/vim -g folder, how'd you do that? Please outline the steps you are using.
    – Plakhoy
    Sep 14, 2013 at 22:22

3 Answers 3

8

To build Vim you will need first to install all the dependencies. This could be done using

$ sudo apt-get build-dep vim-gtk # or vim-gnome, if you prefer.

This will download and install a lot of packages that should only be needed to compile Vim. If you don't want to keep them, before running that command add this to /etc/apt/apt.conf

APT {
  Get {
     Build-Dep-Automatic "true";
  };
};

This will make all the packages installed with build-dep be "marked to be autoremoved". So after you finished compiling Vim you can uninstall them using sudo apt-get autoremove.

After this, just proceed with the usual steps:

$ ./configure --with-gui=gtk2 # or gnome
$ make -j 4
$ sudo make install  
1
  • For me on Ubuntu 20.04 LTS sudo apt-get build-dep vim-gtk showed error until I added "Source code" checkbox in Software&Updates on "Ubuntu Software" tab. Then I made sudo apt-get update and command worked.
    – Dmitry
    Oct 8, 2020 at 19:57
3

If you call ./configure --enable-gui=auto, the build process will automatically build against whichever GUI libraries are available. A cursory glance suggests that gtk2 will be prioritised over gnome2.

1

Just run into the same issue on Ubuntu 16.04. Turns out, it happens because packages with headers/libs for GTK2/Gnome aren't installed. After sudo apt-get install gnome-devel as @RAOF advised in this post, vim --version says it has GUI GTK2 support and gvim, gvimdiff, gview symlinks are created during install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.