I recently bought a Lenovo G500, and had a rather entertaining time trying to get Ubuntu installed. Since it came with Windows 8 installed it turned out to be an unexpected challenge. For anyone with a Lenovo product you are likely to run into the same problem, essentially it refused to even see a new SSD drive I transplanted from another computer.

Thus began my little journey. Windows 8 machines utilize UEFI instead of BIOS and the kicker is that you can only get to it by going through Windows. This can be done by going to the lower right hand corner and hitting Settings. Then change settings, and then General. Scroll down to Advanced Options go into it and choose UEFI Settings.

Your machine will then boot into the UEFI/BIOS. You need to enable legacy, set legacy to first, make sure USB boot is enable, and enable BIOS flash back. Ubuntu 12.04 should install normally at this point however the screen will be at its dimmest level or possibly black. Hit the brightness control function key and it should become visible.

Now for my two questions:

  1. Brightness control has two settings really bright close to maximum and really dim close to black with nothing in between, is there a work around to allow finer adjustment? Any information I would need to provide to get an answer please let me know and let me know how to get. I am merely an apprentice when it comes to using Linux.

  2. Touchpad will not turn off, even though I set it to turn off in the settings, what terminal command do I need to add turn it off?

Thank you for any assistance.

  • Do not squeeze multiple questions in a single post. Tackle one doubt at a time. – VedVals Sep 14 '13 at 9:52

Follow the steps detailed on this page:

Screen brightness reset to minimum after every reboot

The file /etc/rc.local add before line exit 0:

echo 5 > /sys/class/backlight/acpi_video0/brightness exit 0

Where 5 is the brightness level from 0 to 10

The max brightness is defined in /sys/class/backlight/acpi_video0/max_brightness. The default is 15 on my laptop. So if you want to set it to 50%, you should use echo 7. – amazingjxq Dec 3 '11 at 3:50

In my Lenovo G500, max brightness seemed to be 100, so I added that line with 'echo 500'. Rebooted and no problem.

  • Did you mean echo 50 in that last line? – Sudhir Dec 9 '13 at 13:21
  • Sorry for the super late reply, I meant 100 as I wanted full brightness. – Sutarmekeg Feb 27 '14 at 10:21

I use Touchpad Indicator - it has what you need to disable your touchpad. You can set the app to autostart, and you can set the app to disable the touchpad when it starts. http://ubuntuhandbook.org/index.php/2013/08/install-touchpad-indicator-in-ubuntu-13-10-saucy/ http://www.webupd8.org/2013/08/touchpad-indicator-095-brings-important.htmli


I'm using Lenovo G500 on ubuntu 13.10 – after a lot of google, here is the solution that worked for me.
Open terminal:

  1. sudo gedit /etc/default/grub
  2. replace the following two lines with this:

  3. save changes
  4. sudo update-grub
  5. restart your notebook
  6. Press FN and (F11/F12) to control brightness
  1. You need go to BIOS first (start from "NOVO" button) and choose "Legacy" boot - NO UEFI in boot menu in BIOS.
  2. Use http://releases.ubuntu.com/precise/ (12.04.03 image ) I use the x64 version. After installing the system you need press F12 ("brightness arise" button 2 sec minimum) for appear brightness and you need press F11 ("brightness down") for less.
  3. I'm NOT USING Windows 8 EVER and clean and make only Linux partition on HDD
  4. All buttons works on my laptop (Lenovo G500) all devises too (wi-fi internet/all Usb ports/ethernet etc) Sorry for my English, but if you have any questions, I'll try give you an answer

update 09/23/2013

I'm sorry sir,

I just do not understand your question. As for the touchpad, you can simply press F6 and turn off the touchpad, as you will be notified as shown in the picture below.


  • Apparently F6 does turn off my touchpad. Thanks for that. – user192775 Sep 25 '13 at 0:50
  • Also I did get it successfully installed the only problem remaining is the brightness which is non responsive even with the function keys. It has only two settings really bright and really dim. – user192775 Sep 25 '13 at 0:51

Make sure you install http://releases.ubuntu.com/precise/ubuntu-12.04.3-desktop-amd64.iso this version (I mean LAST version of distr - issue of 20-Aug-2013 18:08 708M Desktop CD for 64-bit PC (AMD64) computers) while you install system- chek all boxes and update... Why I pay attention to it? Upgrade to 32 bit 12.04.02- I had a problem: I try installed the printer canon mf 3010 -fault!!!Then I reinstalled the system, which I advise you - and it worked the first time! Anyway good luck!!!



You can Install 13.10 Ubuntu/Xubuntu/Lubuntu

This is a very simple thing do.

  1. NoVo Button → Legacy boot → Legacy boot – NO UEFI in boot menu in BIOS.

  2. then insert your 13.10 or other version Ubuntu or other Linux flavour DVD.

The problem is that you cannot see the Ubuntu logo in the screen, It is booting ok. but brightness is the problem.

So please increase the brightness via F12 key. Press it & press it & PRESS IT

Lenovo is a very different laptop. and very Advance one.

That's it.

Eng Naveen G

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.