So I've been looking around and can't find an exact solution to my problem. I dual boot Windows 7 and Ubuntu 13.04. I like Ubuntu and want to use it instead of windows. Everything was working on Ubuntu 13.04 running PMS and a external USB HDD hooked up to it until I got a NAS WD MyBookLive 3TB drive. So I understand with this there are shared folders on this drive. I created a folder called Plex which then has sub-directories:

"MyBook" is the name of the drive

  • MyBook/Plex/Movies
  • MyBook/Plex/TV Shows

I don't know how to mount/map this properly to keep this mounted every time there is a reboot needed. Also I just don't understand how to add it into plex. I know this will be fixed when the shared folder "Plex" is mounted/mapped correctly. I just can't get plex to see it. There isn't a username or password needed to get into the shared folder "Plex". So credentials aren't needed.

IP address of the mybook is

I have read various things and tried several different things, but no luck. If someone could help me I would be grateful. The drive is NFS and Samba compatible.


6 Answers 6


I don't believe Plex has any way to access drives from a network location, but like this thread on Plex for Mac suggests - http://forums.plexapp.com/index.php/topic/58993-add-folder-from-local-network-nas-hdd-in-plex-server-library/ - if you are able to mount them within the local filesystem, then you should be able to do it with no problem.

You'll need to decide where you want the mounted files from MyBook to appear in your filesystem. I would suggest something like /media/Plex. Once you decide, open a terminal and type:

sudo mkdir /media/Plex

(This assumes you don't already have that directory. You'll need to enter your password, because usually only the operating system edits things in /media)

Now, let's install CIFS Utilities:

sudo apt-get install cifs-utils

Then, you'll want to edit your /etc/fstab - this is what tells Ubuntu what to drives to mount (and where) when it starts up. You may wish to backup /etc/fstab first (in case something goes wrong your you want to undo this easily). You can do this by entering in terminal:

sudo cp /etc/fstab /etc/fstab.bak

(Now you've got a backup copy called fstab.bak)

Next, to add your NAS. Still in the terminal, type:

sudo gedit /etc/fstab

This will open /etc/fstab in the text editor with write permissions. Don't touch anything already added to the document, but add to the end of that document this line:

// /media/Plex cifs guest 0 0

Since you said there's no password, guest should work.

*Sidenote: If you use a password protected NAS, use this line instead:

// /media/Plex
username={{username}},password={{password}},iocharset=utf8,sec=ntlm  0  0

And replace {{username}} and {{password}} respectively.*

Now, to test, type in terminal:

sudo mount -a

And open Nautilus (the file manager). Your MyBook's Plex folder should now show up in the left-hand sidebar!

So, also, you should now be able to "Add Section" in the Plex Media Server web UI by clicking the big + sign in the My Library section (below in red).

plex with "add section" highlighted

Select the type of media, and then you should be able to select the Movies or TV shows from your new /media/Plex folder (which is really your MyBook). I did the same thing with what I have available (I don't own a MyBook, but I did the same thing with my readyshare, and here it is after mounting it in /media/readyshare, ready to be added as a Plex section:)

adding a section from a network drive (readyshare)

  • So this worked. My only question now is how do I mount it with write permissions? Everything I can read, but I can't write to the share drive? Commented Sep 17, 2013 at 2:29
  • @JoeCallahan - The problem might be that it's mounting as root so only root can write to it - like this ubuntuforums.org/showthread.php?t=1409720 - we can try that fix. So enter in terminal sudo id user_name (where user_name is your usual username) . Your output should be something like this uid=1000(user_name) gid=1000(user_name) groups=... - take that UID and GID add them to the line in /etc/fstab, so it looks like // /media/Plex cifs defaults,uid=1000,gid=1000 0 0 - if that still doesn't work, try using the UID and GID for sudo id plex
    – drkokandy
    Commented Sep 17, 2013 at 15:11
  • 2
    So I used this to fix my issue "// /media/Plex cifs guest,uid=joe,iocharset=utf8,file_mode=0777,dir_mode=0777,noperm 0 0". I found it here "askubuntu.com/questions/313093/…". This is just in case someone wants a reference. This mounted the plex share drive with rw permissions. Thanks everyone for your help. Commented Sep 20, 2013 at 1:03

Following drkokandy answer, I couldn't get sudo mount -a to work after editing fstab in Ubuntu 18.0.4. Reading this post, I got the following to work instead:

// /media/Plex cifs username={{username}},password={{password}},iocharset=utf8 0  0

I'm a newbie. That being said: The answer for me was to format the external drive from NTFS to ext4 and add the content back on. Then, just Modify the permissions for the Directory (In my case /media/data). It worked like a charm.


I agree with the second response. MAPPING your NETWORK DRIVE works like a charm. Just open your network drive location, right-click on the folder your media is in and select the option to map the drive. I gave mine letter Z but you can pick any available letter. Then when you go back to Plex settings you will see where you have the additional option of adding folders from the lettered drive you just mapped. Lots of words, but on 3 clicks :-)


On a Windows device-

Right click folder - Share folder(advanced share with all) Allow the folders to be shared that are necessary. -Go into Plex go to home folder(click on the + "add button" find network mapped drive) Allow plex to add all files---***** and Done!


On my thecus nas was having problems getting plex to read usb drives. enabled samba and nfs on the usbhdd directory, dont know which worked but plex now sees the media.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .