In Raring, everytime I connect to the network, Cups installs all the printers in the network automatically, some more than once.

Furthermore, I connect a USB printer to the laptop every now and then. Even though the printer is configured already, another printer is added to the list.

I wish to disable this feature and allow only manual installation of printers. How do I go about it?

  • Did you figure out the answer? I am having similar problems on 14.04 and the answers have not worked for me here. My question is at askubuntu.com/questions/477082/…
    – Xu Wang
    Commented Jul 16, 2014 at 22:32
  • No, I didn't want to disable avahi-daemon and I'm no longer connected to the same network. There are no network printers where I am now.
    – To Do
    Commented Jul 17, 2014 at 10:16
  • How do I get rid of all the printers it installed?
    – khatchad
    Commented Oct 30, 2019 at 13:48
  • 1
    @RaffiKhatchadourian before disabling it (or after temporarily re-enabling it) I turned off my wifi and they went away. Then I disabled it with the wifi off. PS: Hi! Commented Dec 10, 2019 at 16:56
  • 2
    I don't understand how it is even a feature
    – Kiwy
    Commented Jul 27, 2020 at 15:47

9 Answers 9


I just discovered a, possibly optimal, solution to this mess. There is as service called "cups-browsed" which apparently is responsible for going out on the network and finding all the printers it can locate and install them for you (gee - thanks --NOT). Since this is an Upstart/Systemd job, you can stop the service with:

For Ubuntu versions 15.04+ (using systemd)

sudo systemctl stop cups-browsed

Followed by:

sudo systemctl disable cups-browsed

You may still start/stop the service manually if you wish with:

sudo systemctl start cups-browsed
sudo systemctl stop cups-browsed

For Ubuntu versions prior to 15.04 (using upstart)

sudo service cups-browsed stop

Even better, you can prevent the service from ever starting again by adding a simple text file to /etc/init that contains the single word manual. The file must be named cups-browsed.override

So, just start up gedit with

gksudo gedit /etc/init/cups-browsed.override

put manual in the first and only line and save the file.

On the next Reboot, the service will not be re-started. However, you need not reboot if you've already stopped the service. Once you've placed this file in /etc/init, the service can only be started manually (if and when you need/want it) using:

sudo service cups-browsed start
sudo service cups-browsed stop`

I have tested this over one reboot. Printing still works fine and so far I am not getting several hundred printers installed anymore after the reboot. Just the ones I installed manually show up.

  • 28
    Ubuntu 15.04 and later (they moved to systemd): sudo systemctl disable cups-browsed Commented Mar 3, 2016 at 17:58
  • 5
    It doesn't work for 18.04
    – eetsurt
    Commented Jan 11, 2019 at 6:04
  • 6
    not working for me on 20.04
    – joel
    Commented Aug 21, 2020 at 13:24
  • 1
    There are two mechanisms how Ubuntu auto-adds printers. The first one is cups-browsed and can be stopped like this. The second one is cups adding printers itself. There is no easy way to stop the second one except with a load of messy patches. Just braindead. Commented Oct 22, 2020 at 7:37
  • 4
    confirm not working on 20.04... the abomination of this mess continues. Commented Apr 28, 2021 at 19:44

In /etc/cups/cups-browsed.conf, set directive:

BrowseProtocols none

Afterwards, run service cups-browsed restart and service cups restart. There should be no printers visible, except those you've added yourself.

  • This is the most straightforward solution for 15.10.
    – Mustafa
    Commented Oct 27, 2015 at 19:19
  • 1: that is for sharing the current device's printer(s) to the network, not for showing network printers.
    – Alex R
    Commented Apr 18, 2016 at 7:50
  • Correct, only step 2 is necessary, and is more correct than the hack in the currently upvoted answer. Please fix your answer to avoid adding confusion to an already confusing answer!
    – kiko
    Commented Jul 20, 2016 at 18:07
  • There was one particular printer on my network that kept re-adding itself after being deleted. I set this option, rebooted, and it fixed the issue. I am using Debian 9. Thanks
    – jbrock
    Commented Aug 31, 2017 at 14:40
  • 2
    this solution is work for 18.04
    – eetsurt
    Commented Jan 11, 2019 at 6:04

As mentioned earlier, this is now done in the client-side cups libraries (ie libcups.so, which GNOME and KDE apps link against) and not in the cupsd server. So changing the "Browse" settings in the cups server won't work.

$ ldd /usr/lib/x86_64-linux-gnu/libcups.so.2
libavahi-common.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-common.so.3
libavahi-client.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-client.so.3

IE this behaviour (of showing remote printers in the Print dialog box) happens even if you turn off your local cups server. You can disable it by turning off the avahi service, but that will disable all zeroconf/mdns related functionality.

However, there is at least a way to turn off most of avahi's functionality (including adding remote printers into the CUPS clients) while keeping the DNS functionality (eg when looking up foo.local-style host names):

edit /etc/avahi/avahi-daemon.conf and in the [server] section, add enable-dbus=no then restart the avahi-daemon service.

  • 2
    Why does enable-dbus=no prevent avahi discovery of printers and what other avahi functionality will be affected by this config change?
    – gene_wood
    Commented Dec 23, 2015 at 19:09
  • 2
    I made this change and it did indeed prevent auto discovered printers from showing up in the list of printers, however my goal was to make the printer dialog come up more quickly (it normally takes 5 to 10 seconds). This change made it take longer for the printer dialog to come up (long enough that Ubuntu dimmed the dialog thinking that it wasn't responding). Hmm.
    – gene_wood
    Commented Dec 23, 2015 at 19:26
  • 1
    Worked for me. But I have the same problem as gene_wood. It takes ~5s to load the much-shortened printer list. Commented Feb 20, 2018 at 9:43
  • 1
    Try adding browse-domains=local.local in your avahi-daemon.conf instead of disabling d-bus. That should avoid the delay.
    – istepaniuk
    Commented May 13, 2020 at 17:09
  • 2
    I have had a very nasty side-effect by "sing enable-dbus=no". Libreoffice writter stalled for 30-40 seconds every time I open some files. LO tries to find the printer at file opening involving avahi somehow and stalled for 30 to 40 seconds each time. New files have no problem if they have not been printed yet. The lag also happen each time I enter the printing menu in LO or the printer configuration menu in Ubuntu. Tested in 18.04 and 20.04. It took me more than a year to find out it was related to disabling dbus in avahi, so I do not recommend to use this approach.
    – jjchico
    Commented Sep 17, 2020 at 14:08

I tried all of the above. Modifying Cups did not work in Linux Mint 20, which is based on Ubuntu 20.4. Apparently, Ubuntu and Mint no longer use Cups for Printer discovery, but instead now use Avahi. I think it is a Systemd thing. Setting enable-dbus=no in avahi-daemon.conf somewhat worked, but caused the print menu in LibreOffice to take a long time (maybe 20-30 sec.) to show up, and thus was not a good solution.

The following did work, however, very well:

sudo nano /etc/avahi/avahi-daemon.conf

In that file:

change “use-ip4=yes” to “use-ip4=no”

change “use-ip6=yes” to “use-ip6=no”

Now, only printers that I added manually show up in the "Printers" control panel (Printers-localhost), the HPLIP Toolbox and LibreOffice.

  • 1
    This is a piece of genius! It disable avahi without disabling it! :-)
    – ciampix
    Commented Jan 22, 2021 at 7:55
  • 1
    @ciampix yes it does get the job done for me in Ubuntu 20.04 - except I have found out, that if I configure both ipv4 and ipv6 to "no", upon systemctl start avahi-daemon, the daemon fails to start. Thus, the same effect would probaby be achieved simply by systemctl stop avahi-daemon, maybe followed by a "disable" to prevent automatic re-appearance on the next boot...
    – frr
    Commented Jun 10, 2021 at 9:57

The cups client libraries now also get a list of network printers from Avahi (which implements the protocol known variously as zeroconf or Bonjour or mdns or dns-sd). In older versions of cups, this was only done by the cups server.

You can see what is being broadcast on your network with a shell command like avahi-browse -a | grep Printer

You can disable avahi with sudo service avahi-daemon stop, but that will stop all zeroconf based setup, not just printers.


To disable it simply open terminal Ctrl+Alt+T and type

 sudo cupsctl --no-remote-printers

or to edit the


and set

Browsing Off

This solution was found here

Some newer Ubuntus (15.04 and up) may need this command instead:

sudo cupsctl --no-share-printers
  • 5
    I still have this problem, although my cupsd.conf already contains "Browsing Off". Running the cupsctl leads to the following error: cupsctl: Unknown option "--no-remote-printers" Usage: ... Commented Oct 21, 2013 at 12:16
  • Forgot to mention, I'm on Ubuntu 13.10 Commented Oct 21, 2013 at 15:22
  • 1
    @CatalinHritcu, How about setting BrowseLocalProtocols none?
    – user.dz
    Commented Mar 20, 2014 at 12:10
  • 1
    this is for the local machines sharing not for not adding remote printers.
    – Alex R
    Commented Apr 18, 2016 at 7:50

It's quite simple to make it stop.

  1. Remove the unwanted printers. Then:

    sudo nano /etc/cups/cups-browsed.conf
  2. Change this line: BrowseRemoteProtocols dnssd cups (or whaterver is after it) to none so it reads: BrowseRemoteProtocols none .

  3. Then save the file and reboot.

Solved the problem for me.

  • This seems to be a duplicate of the answers on Mar 20, 2014 and Dec 5, 2014 Commented Nov 16, 2015 at 15:54

Found the solution, if you disable bonjour in HP (probably other printers too) the mystery printer detection is an issue of the past.

  • After being annoyed by this problem for MONTHS, this ended up being by far both the simplest solution and most reliable solution.
    – Patrick F
    Commented Aug 12, 2021 at 5:30


  1. Open http://localhost:631/admin/ → Edit Configuration File or Edit /etc/cups/cupsd.conf

  2. Change:

    # Show shared printers on the local network.
    Browsing Off
    BrowseLocalProtocols none

Reference: cupsd.conf: BrowseLocalProtocols

  • 1
    Unfortunately, this didn't stop remote printers from being added for me.
    – azimut
    Commented Nov 4, 2014 at 10:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .