I have 4GB usb flashdrive I tried to format with Widows 7 and couldn't format it any way I tried with Kali Linux (a pentesting Debian distro) to format my RAW usb flash drive (as detected on Windows 7) when I try to format it with GParted to fat32 it says Input/outpout error during write on dev/sdf I did Retry but it took a very very long time trying to format so I aborted the operation than I tried dd if=/dev/sdf1 of=~/flashdrive.img but this

dd: reading `/dev/sdf1': Input/output error
12776+0 records in
12776+0 records out
6541312 bytes (6.5 MB) copied, 649.385 s, 10.1 kB/s

please how to fix the flashdrive? Thank you very much

  • I had the same problem once before, with a 4GB flash drive as well. It was detected as RAW in Windows, just like yours. In Ubuntu, it would also give me that Input/output error, just like yours. I tried everything to bring it back to life. Formatting. Writing with zeros, ones and random. "Low level formatting" tools. Everything. But it never came to life. I threw it in the dumpster =/. – Alaa Ali Sep 13 '13 at 22:41

That flash drive is most likely busted. If you want to see all the errors do ...

dd if=/dev/sdf1  of=~/flashdrive.img conv=noerror,sync

The terminal probably can not buffer all the errors you get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.