7

I am trying to install Ubuntu on a Dell Inspiron 1545 which is using an external monitor (LCD is broken). The external monitor is an AOC e950Swn and the LCD is complety unpluged from the MOBO, if that matters.

I have and old (3 months) installation in a HDD, and the GRUB shows up, but when I select Ubuntu to boot the screen goes off saying there is no signal.

I've tryed installing from a USB. When booting I press F2 so it takes me to the advanced menu. There I have chosen "nomodeset" but all I see are some error messages related to the wireless card and then the screen goes off.If booted without "nomodeset" I can't even see the error messages.

Also tried installing on another laptop and passing the HDD, but still doesn't work. If I log in recovery mode and try safe graphics mode all I get is a blinking console cursor. But if I log into a root console everything is there.

My assumptions is that it tries to turn on the laptop's LCD even if it isn't present, completely ignoring the external monitor.

So, how can I tell it (or force it) to load the external monitor from startup? or even when installing.

  • Have you tried plugging the monitor in after the OS boots? It might detect the monitor and change the display settings automatically. I know this this happens with 12.04, but I've never tried with a broken monitor – kbuilds Sep 13 '13 at 1:27
  • Yes, I have tried. Still does not work – Ángel Araya Sep 14 '13 at 0:37
  • Have you looked at this question: askubuntu.com/questions/356950/… – Arman yaraee Dec 10 '13 at 3:18
  • Im not sure where should I put the lines to test it, can you tell? – Ángel Araya Dec 10 '13 at 4:32
7
+150

If you can't access your system but GRUB is shown then press e on the Ubuntu menu entry in grub2, this will take you to edit mode and add the following option to the kernel line (add it to the end of the line which starts with "linux")

video=LVDS-1:d

Then press CTRL+x to boot with the edited kernel command line.

If it doesn't work try it with video=LVDS-0:d or to force output to VGA with video=VGA-1:e or video=VGA-0:e . More on these parameters here.

After you succeed with the boot just edit your /etc/default/grub and add the working kernel line parameter to the GRUB_CMDLINE_LINUX_DEFAULT= line to disable the LVDS output.After you edited the file run

sudo update-grub

To save the kernel line for for later boots.

  • Thank you, I only had to disable the LVDS panel to got it working but maybe forcing the VGA is helpful to someone else. – Ángel Araya Dec 11 '13 at 3:23
  • 2
    What if GRUB isn't even shown? – Jonathan Sep 30 '14 at 6:28
  • What about on the ubuntu mini.iso installer? – Samy Bencherif Aug 19 at 14:25
0

when you boot up make sure the monitor is unplugged...let the booting process finish,plug in monitor it may still say "no signal"...at that point hold the Fn(function) and long press F8...this will manually switch from your built in display to the external

  • Already tried, it doesnt turn the display to the external monitor. – Ángel Araya Dec 9 '13 at 21:29
0

IMPORTANT!!!

Before trying solutions above, firstly change displays settings to "Single Display" from display settings, not use "Join Display" or "Mirror"
This is worked for me;
1- Select "Single display" 2- Run: sudo gedit /etc/default/grub
3- Add: GRUB_CMDLINE_LINUX_DEFAULT="video=LVDS-1:d video=VGA-1:e"
4- Run: sudo update-grub
5- And restart. This is the way of how to do this steps. "video=..." settings can be changed, try to use correct one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.