I've done some researching over the internet and this seems to be... I don't know... a hardware problem? I can't tell exactly. One thing I know for sure is that it happens to a lot people in Windows and they can't solve it by tinkering with settings (duh, cause it's happening outside of windows) but some people seem to be able to fix it by updating USB drivers, so...

Here's the problem... and it's only intermittent; however it IS happening to me right now and I figured it was a great opportunity to post some console output to try and gleam as much information as possible:




USB 3.0 devices are sometimes not detected when connected to a USB 3.0 port; however work fine when connected to a USB 2.0 port.


So I initially had an ASUS RoG G74Sx laptop with 1 USB 3.0 port and 3 USB 2.0 ports. This is when I first noticed the problem. I have a WD 3TB MyBook external hard drive. One day I noticed that it was not detected in the USB 3.0 port but it was detected in any of the USB 2 ports. I plugged the drive into a Windows laptop with USB 3 and everything seemed to work okay. What made even less sense is that this also caused it to be redetected by the G74Sx (running Ubuntu 13.04). I actually had this come up a few more times over the next week or two and was starting to surmise that Ubuntu has spotty support for USB 3 connectivity.

When I say it happened a few more times I mean randomly one morning I would go to plug the MyBook into the USB3 port and it would not be detected after working fine the night before. It always works in USB2 and sometimes would be detected in the USB3 port after a system restart or after successfully connecting to a USB3 port in another machine (usually windows 7).

After two weeks the issue ceased and the MyBook would always be detected by the USB3 port. I don't know what happened. I made no changes to BIOS, firmware, or any OS installations. It just started working.


break; as in no new info for a few months


So last week I grabbed an ASUS N56VZ (two in fact) and an ASUS S56CM and threw Ubuntu 13.04 on both (had to disable secure boot for S56CM since it was a windows 8 laptop). Now most things have been going fine except for nVidia Optimus (but I won't get into that here) until this morning I woke up and the USB3 port would not detect the WD MyBook (again this an external hdd). The port itself is not busted as I can plug a USB mouse into it but I have no other USB3 devices to test; however the MyBook works fine in several other laptops both in Ubuntu and Windows.

So I've confirmed I can plug the MyBook into either of my N56VZs running Ubuntu 13.04 and those laptops ONLY have USB3 ports. The MyBook is also detected by another laptop in Windows 7 on the USB3 port. Unlike in the past, no amount of system restarting or getting the MyBook to boot on other devices allows it to be detected by my S56CMs USB3 port and the MyBook can always be detected by USB2. And so far, I have not been able to get the USB3 port to detect my USB3 device since this morning (but it IS working with a USB mouse).

lsusb has the same output with/without the drive connected. Here is the tail of dmesg when I plug the drive into the USB3 port (drive responds and so does system but it never gets successfully connected):

[  287.115279] usb 4-1: new SuperSpeed USB device number 2 using xhci_hcd
[  287.132077] usb 4-1: New USB device found, idVendor=1058, idProduct=1140
[  287.132088] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[  287.132094] usb 4-1: Product: My Book 1140
[  287.132099] usb 4-1: Manufacturer: Western Digital
[  287.132103] usb 4-1: SerialNumber: 574341575A32363535333139
[  287.148226] Initializing USB Mass Storage driver...
[  287.149341] scsi6 : usb-storage 4-1:1.0
[  287.149934] usbcore: registered new interface driver usb-storage
[  287.149940] USB Mass Storage support registered.
[  288.147116] scsi 6:0:0:0: Direct-Access     WD       My Book 1140     1012 PQ: 0 ANSI: 6
[  288.147537] scsi 6:0:0:1: Enclosure         WD       SES Device       1012 PQ: 0 ANSI: 6
[  288.149609] sd 6:0:0:0: Attached scsi generic sg3 type 0
[  288.150005] scsi 6:0:0:1: Attached scsi generic sg4 type 13
[  288.151177] sd 6:0:0:0: [sdc] Spinning up disk...
[  296.161509] scsi 6:0:0:1: Failed to get diagnostic page 0x8000002
[  296.161527] scsi 6:0:0:1: Failed to bind enclosure -19
[  296.161567] ses 6:0:0:1: Attached Enclosure device
[  289.152700] ........ready
[  303.181164] sd 6:0:0:0: [sdc] Very big device. Trying to use READ CAPACITY(16).
[  303.181502] sd 6:0:0:0: [sdc] 5860466688 512-byte logical blocks: (3.00 TB/2.72 TiB)
[  303.181512] sd 6:0:0:0: [sdc] 4096-byte physical blocks
[  303.181965] sd 6:0:0:0: [sdc] Write Protect is off
[  303.181977] sd 6:0:0:0: [sdc] Mode Sense: 47 00 10 08
[  303.182403] sd 6:0:0:0: [sdc] No Caching mode page present
[  303.182415] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[  303.183277] sd 6:0:0:0: [sdc] Very big device. Trying to use READ CAPACITY(16).
[  303.185078] sd 6:0:0:0: [sdc] No Caching mode page present
[  303.185088] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[  303.236864]  sdc: sdc1 sdc2
[  303.237960] sd 6:0:0:0: [sdc] Very big device. Trying to use READ CAPACITY(16).
[  303.238638] sd 6:0:0:0: [sdc] No Caching mode page present
[  303.238650] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[  303.238661] sd 6:0:0:0: [sdc] Attached SCSI disk
[  304.286643] hub 4-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
[  304.318630] usb 4-1: USB disconnect, device number 2
[  304.322483] scsi 6:0:0:0: rejecting I/O to offline device
[  304.322498] scsi 6:0:0:0: [sdc] killing request
[  304.322540] scsi 6:0:0:0: [sdc] Unhandled error code
[  304.322548] scsi 6:0:0:0: [sdc]  
[  304.322553] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[  304.322575] scsi 6:0:0:0: [sdc] CDB: 
[  304.322579] Read(16): 88 00 00 00 00 00 00 00 01 7a 00 00 00 08 00 00
[  304.322592] end_request: I/O error, dev sdc, sector 378
[  304.322595] quiet_error: 54 callbacks suppressed
[  304.322598] Buffer I/O error on device sdc1, logical block 43
[  304.322611] scsi 6:0:0:0: rejecting I/O to offline device
[  304.322614] scsi 6:0:0:0: [sdc] killing request
[  304.322620] scsi 6:0:0:0: [sdc] Unhandled error code
[  304.322622] scsi 6:0:0:0: [sdc]  
[  304.322623] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[  304.322625] scsi 6:0:0:0: [sdc] CDB: 
[  304.322627] Read(16): 88 00 00 00 00 00 00 04 09 50 00 00 00 08 00 00
[  304.322638] end_request: I/O error, dev sdc, sector 264528
[  304.322640] Buffer I/O error on device sdc2, logical block 336
[  304.322643] Buffer I/O error on device sdc2, logical block 337
[  304.322645] Buffer I/O error on device sdc2, logical block 338
[  304.322647] Buffer I/O error on device sdc2, logical block 339
[  304.322649] Buffer I/O error on device sdc2, logical block 340
[  304.322652] Buffer I/O error on device sdc2, logical block 341
[  304.322654] Buffer I/O error on device sdc2, logical block 342
[  304.322656] Buffer I/O error on device sdc2, logical block 343
[  304.322678] Buffer I/O error on device sdc2, logical block 336

UPDATE: So I was initially ignoring the bad cable warning because... although I switched to a longer USB3 cable this morning, it was working on other devices.

It turns out that the cable that came with the drive works fine (this could have also been my problem with the G74Sx in the past) and the longer cable I bought doesn't want to work with.... some laptops?

Hopefully someone can tell me if there is information in the dmesg output that says why this cable isn't working on THIS machine Works fine in Ubuntu or Windows on different laptops... and does this have anything to do with there being only 1 USB3 port?

Although I personally don't experience any USB3 connectivity problems in Windows, I've read that a lot of people do so I doubt this is OS related. It also seems that PCs without USB2 ports do NOT have the problem.

My local Canada Computers has been selling a lot of garbage quality cables lately so I'm going to head up to the store to ream them out for the last $100 I've wasted on cables that break a few weeks after the warranty but if anyone can shed some more light on this issue it would be greatly appreciated. I imagine the cable isn't the ONLY problem when it's working on 3/5 machines.

I will let everyone know if the problem persists with a higher quality cable...

I'm just thinking out loud here before finally posting: It's gotta be something to do with firmware or hardware drivers or something? I've read some people had fixed the problem in windows by updating drivers, but I know ASUS website only has USB drivers for windows... the only thing they have supported for Linux is BIOS updates.

Since machines with only USB3 work fine, I can only imagine they have better drivers/firmware?

If this is a drivers issue, is there a way to get improved USB drivers in Ubuntu?

Would good/poor drivers make the difference in whether a device can use a lower quality cable?

Lastly, have I actually solved my problem? This cable is currently working on 1 machine with only USB3 and Ubuntu AND working on a machine with 1 USB3, 2 USB2 and Windows 7; but does not work on the S56CM with 1 USB3, 2 USB2 and Ubuntu (I don't feel like formatting to see if it works on Windows; I don't use Windows, don't like Windows, the Windows machines belong to other people in my house); however the original smaller cable that came with the MyBook works all around.

Given all that physical information combined with the output of dmesg suggesting it's a bad cable: the most logical conclusion I could arrive at is that I have a bad cable (also combined with the knowledge that the distributor I bought the cable from has been selling some crap cable lately). So would the majority agree that it's a bad cable? Is there anything else going on here? Or is everything the result of this bad cable? I'm considering to buy another cable because I need a longer USB3 but don't know if I should go for a completely different manufacturer because all their cables are poor quality or if I just have one faulty cable in a line of good ones.

closed as off-topic by Braiam, falconer, Seth, Luis Alvarado Feb 7 '14 at 20:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, falconer, Seth, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.


It turned out to be a low-quality USB3 cable. The one that came with my drive worked fine and the one I purchased from Canada Computers worked intermittently. I am currently communicating with store/stock managers to get them to purchase higher quality cables. I've had over $100 worth of cable break within months of the warranty expiring. Thanks for reading and for your comments.

Not the answer you're looking for? Browse other questions tagged or ask your own question.