3

I have recently procured a Reliance Netconnect+ USB connection for accessing internet. I have the following observations:

  1. Netconnect+ Modem is detected by Microsoft Windows but is not detected "visually" by Ubuntu 13.04 In fact, when I tried using lsusb and dmesg, I can actually "see" that the modem (which is said to act both as CD and USB), is detected.

  2. I have tried using gnome-ppp and wvdial and both "fail" to detect the modem interface wise. However, the vendor, in this case Reliance, assures that the modem works in Ubuntu.

0
5

Do not panic. Its not at all difficult.

First and formost thing is connect your ubuntu desktop or laptop to internet using ethernet connection or any other connection which is possible.

Update your system with following two commands in terminal window. ( Ctrl + ALT + T )

sudo apt-get update  
sudo apt-get upgrade

With this commands your Ubuntu system is updated.

Now install following packages using terminal window.

 sudo apt-get install usb-modeswitch

 sudo apt-get install wvdial

Now put your Reliance netconnect+ usb modem into to usb drive. After waiting for about 20 seconds, you can give following command in terminal window

lsusb

Note down ZTE WCDMA Technologies device id and product id on a piece of paper.

In my case it was 19d2:ffe9

Here 19d2 is device id and ffe9 is a product id.

Create new file using following file.

sudo nano /etc/udev/rules.d/90-zte.rules

Enter following code. [ everything is one line ]

SUBSYSTEM=="block",SUBSYSTEM=="scsi",ATTRS{model}=="USB Storage FFE9",ACTION=="add",RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0xffe9"

and save this file. Please remember to change the vendor id and product id as noted down on piece of paper earlier.

Now give following command and press return.

sudo /sbin/modprobe usbserial vendor=0x19d2 product=0xffe9

On command prompt type following command.

sudo wvdialconf /etc/wvdial.conf

This will create wvdial.conf file in your /etc directory.

edit this file using following command.

sudo nano /etc/wvdial.conf 

remove ; before username and password.

username = your 10 digit mdn number
password = your 10 digit mdn number

save this file.

Now you can create a connection in network management under Mobile Broaband

Gve anyname for the connection say "Reliancenetplus"

Number should be #777
Username is : mdn number
password is : mdn number 
  • mdn number is like your mobile number in 10 digit. Save this connection.

Disconnect your earlier connection using wired or broadband connection.

From network manager you will now see Reliancenetplus . Just click.

You are now connected...

Enjoy.

1
  • This solution was one of those which I have tried earlier and it does not work on my system. – Indian Nov 17 '13 at 16:53
0

I understand that this question is about the Reliance Modems but I have been using Tata Photon+ with Ubuntu since mid-2011.

I have been using it with Ubuntu 10.04 through to 13.04. Previously there existed a script which had to be executed with root privileges (I do not know if such a script exists anymore).

Similarly, as far as I know, Reliance netconnect also supplied a script which worked to create a dash (I don't really know what that is), at least in Mint 13 (Yes I understand that this is an Ubuntu forum).

As far as my understanding goes, these Huawei devices need to be first read by a Microsoft Windows PC and then they are detected in linux-boxes.

You could check your network manager script or configuration file for the top taskbar to display an icon for wireless modem. Also, enable mobile networking. It wouldn't provide you a dash like in windows[that tataphoton.exe which flashes everytime you connect it] because ifconfig -a reads the device as a PPP0 device. So, you will be required to configure it only via network manager.

Going to network manager menu where you add the mobile networking device, give username and password to connect after you select your country and provider. Once the IMEI number is detected, it should be working.

1
  • The Reliance Netconnect modem happens to be a ZTE device. – Indian Oct 3 '13 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.