3

First, a bit of background. I managed to dual boot Ubuntu 13.04 with Windows 8(preinstalled). I disabled secure boot. I had to go in the bios settings and change the disk order to select Ubuntu as the first disk(it created Ubuntu as a boot device). Grub would open and I only saw Ubuntu. I opened Ubuntu and ran boot repair and then when I rebooted I could see Ubuntu and windows 8. Both OS' worked perfectly.

After messing up Ubuntu, I decided that a reinstall was in order. However I decided to install elementary OS over Ubuntu. Since I only had 1 partition for Ubuntu (not counting swap) I simply deleted the partition, recreated a ext4 partition, and left the boot loader in its default place (dev/sa I believe ). Rebooted, again only option was elementary OS, so I ran boot repair once again, and sure enough I got my windows 8 back. Tried both and they both worked. I then was having a bit of trouble with elementary OS, so I decided to reinstall Ubuntu again. I repeated the same steps as before, deleted the 1 partition which contained elementary OS, and installed Ubuntu on a newly created partition.

This is where my problem begins. Upon rebooting after finishing the install, I would only get a blank screen. So I decided to look at my bios settings again and I noticed that elementary was still in the boot devices, instead of Ubuntu. I thought maybe booting in the live usb and running boot repair again would fix it. Ran the recommended action, rebooted and still got the blank screen. Looked at the boot devices in bios and elementary is still there.

I've tried a couple of different settings in boot repair, however I always get the blank screen. For some reason I cannot seem to remove elementary from the boot device list. Before installing elementary, Ubuntu was a boot device that I could pick from.

Any ideas on how to remove elementary from there and re-add Ubuntu so I can load grub and pick from my two OS'?

8
  • So you boot, see the normal logos, and then just a black screen? You can't get a grub menu?
    – Richard
    Sep 11, 2013 at 23:38
  • 1
    askubuntu.com/questions/343432/… You may be able to use UEFI menu or command line efibootmgr. sudo efibootmgr -v The "-v" option displays all the entries so you can confirm you're deleting the right one, and then you use the combination of "-b ####" (to specify the entry) and "-B" (to delete it). Examples $5 is delete: linux.dell.com/cgi-bin/gitweb/… software.intel.com/en-us/articles/efi-shells-and-scripting
    – oldfred
    Sep 12, 2013 at 0:50
  • @searchfgold6789 I see the regular boot sequence, however once the grub menu would normally be there, I get a blank screen.
    – Moosehead
    Sep 12, 2013 at 0:57
  • 1
    @oldfred - My man! That worked beautifully. I managed to delete the elementary boot device from efibootmgr. I then re-ran the boot repair, crossed my fingers and rebooted and BAM grub menu is back and both OS' are listed and working perfectly. Next time beer is on me.
    – Moosehead
    Sep 12, 2013 at 11:09
  • 1
    @oldfred I wonder if you could possibly do the site a huge favour and write an answer to this - I can't upvote OP's answer which is copied and pasted from your comment and I don't find it very clear.
    – Zanna
    Oct 22, 2016 at 9:00

1 Answer 1

1

Using @oldfred's advice

I booted from live USB and ran

sudo efibootmgr -v 

The "-v" option displays all the entries so you can confirm you're deleting the right one. The output looks something like

BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0001,0002,0003,0004,0005
Boot0000* elementary    HD(1,GPT,887f27c1-1cfd-42a8-8d04-c3b41ba74a74,0x800,0x100000)/File(\EFI\UBUNTU\GRUBIA32.EFI)
Boot0001* Windows Boot Manager  HD(1,GPT,887f27c1-1cfd-42a8-8d04-c3b41ba74a74,0x800,0x100000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)
Boot0002* ubuntu    HD(1,GPT,887f27c1-1cfd-42a8-8d04-c3b41ba74a74,0x800,0x100000)/File(\EFI\UBUNTU\GRUBX64.EFI)
Boot0003* UEFI:CD/DVD Drive BBS(129,,0x0)
Boot0004* UEFI:Removable Device BBS(130,,0x0)
Boot0005* UEFI:Network Device   BBS(131,,0x0)

Then you use the combination of -b #### to specify the entry and -B to delete it, say I want to delete Boot0000* elementary HD..., I would do:

sudo efibootmgr -b 0000 -B

See man efibootmagr or the efibootmgr man page

I deleted the elementary menu entry and ran boot repair again. This time everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.