I am trying to connect to my Facebook account from Empathy on Ubuntu 13.04.

When setting up the account in Empathy everything looks OK, but then Empathy just shows the message:

Facebook account requires authorization

According to bug #1170832, this is due to a problem in the telepathy-gabble package which has been fixed in version 0.18.1.

However, I manually installed telepathy-gabble_0.18.1-1_amd64.deb from Launchpad and the problem persists. Has anyone else had any luck with this?


The telepathy-gabble 0.18.1 package in Ubuntu actually contained a work-around for the problem, not a proper solution. Quoting from the ChangeLog:

telepathy-gabble (0.18.1-1) unstable; urgency=low

  * New upstream stable release
    - work around Facebook server behaviour change so we don't consider its
      service discovery response to be spoofed (Closes: #721883)

 -- Simon McVittie  Mon, 09 Sep 2013 13:05:13 +0100

Apparently, this work-around does not work, and in fact the status of the bug has been reverted from Fix Released to Confirmed.

For the proper fix I'm sorry you will have to wait for the upstream bug to be fixed (unless someone proposes an another work-around in the meantime).


Had the same problem and been looking at the suggestions.

On Ubuntu 13.10

What worked for me:

  1. Removed fb account from online account in settings.
  2. Went to fb on firefox and the little gear>account settings>apps>removed access of ubuntu.
  3. Re-entered fb account on online accounts on desktop this time using the fb "username" only NOT the email address.

That worked for me.

Hope this helps.



Just a couple suggestions you might try...

No-1. Log into facebook and turn off notifications for log-ins... Facebook > Account Settings > Account Security (change) > Change "Would you like to receive notifications for logins from new devices?" to NO.

No-2. Try logging out of facebook and logging back in (with the "facebook username", not email)

More suggestion and info here → http://ubuntuforums.org/showthread.php?t=1487433

Hope this helps... Good Luck!

  • Yeah I tried that already, did it work for you ? – jpic Oct 5 '13 at 8:22
  • Didn't work for me – pylover Oct 28 '13 at 4:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.