8

I installed kubuntu 13.10 beta 1 yesterday. Today, I installed bumblebee and I was tried to check my fps on video card. When I ran glxspheres an error command not found appeared. How can I install glxspheres?

I tried sudo apt-get install virtualgl but the package was not found.

10
  1. Download VirtualGL (.deb) from: http://sourceforge.net/projects/virtualgl/files/VirtualGL/
  2. Navigate to the folder containing the deb package and install it with:

    sudo dpkg -i VirtualGL_*.deb

  3. Run glxspheres:

    cd /opt/VirtualGL/bin/

    ./glxspheres

    OR

    /opt/VirtualGL/bin/glxspheres

4
  • bash: /opt/VirtualGL/bin/glxspheres: File not found
    – set4812
    Sep 11 '13 at 12:34
  • My error :( i need run glxspheres64 thx for help :)
    – set4812
    Sep 11 '13 at 12:41
  • The website address should now be: sourceforge.net/projects/virtualgl/files/VirtualGL pick the newest stable version, and then choose the deb release.
    – BenB
    Jan 14 '14 at 0:36
  • Note: glxspheres seems to be /usr/bin/glxspheres64 in the x86_64 virtualgl package nowadays.
    – Weekend
    Apr 28 '17 at 3:48
2

In 13.04 and older it is provided by mesa-utils package:

$ sudo apt-get install mesa-utils

Also in older releases virtualgl is not in the default repositories. If this is still the case you can use Bumblebee PPA to get it.

4
  • I have added this PPA but now bash sad virtualgl is the latest version and glxspheres not found :(
    – set4812
    Sep 11 '13 at 12:39
  • So, even after doing that apt-get install you still get that error with glxspheres?
    – Salem
    Sep 11 '13 at 12:41
  • @Salem he's using Ubuntu+1, or more accurately Ubuntu 13.10 Saucy Salamander, hence, normal methods could not work.
    – Braiam
    Sep 11 '13 at 12:54
  • 1
    This is the most native and easiest one. Only sphere won't be there but glxgears can do the job or it's friends.
    – Ikon
    Dec 20 '13 at 10:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.