I seem to have lost the button on the Unity panel (left hand side panel) in Ubuntu 11.04 which shows you the desktops (like compiz expo does) think the button is just a shortcut for the expo compiz effect.

But in any case, How do I get the button back ? It is called the Workspaces switcher from what I could see from other mockups etc ...

Any help appreciated to get it back


I also lost my workspace switcher somehow, but got it back by checking the "Enable workspaces"-checkbox in "Appearance -> Behavior"

  • thank you, this is exactly what I needed, worked on 13.10 thanks – Malachi May 10 '14 at 4:09

Have you tried rebooting, or logging out and back in? If it is still missing, try resetting Unity with the command unity --reset.

If that doesn't work, try the command unity --reset-icons.

The workspace icon in the launcher shouldn't be able to be moved or deleted, as it is fixed.

  • Thanks, the unity --reset got the icon back, good to log out then and start desktop again. – user14011 Apr 15 '11 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.