28

I am trying to use my two monitors when I use Remmina remote desktop client. There is no option for using all monitors like RDP in Windows.

Does any one know how can I accomplish that with Remmina?

This is the option I'm talking about in Windows RDP:

1
  • I've added multi monitor support from Remmina 1.4.11, it's still experimental, and I count on some testing to reach a good maturity level. – tmow Apr 19 at 14:57
29

I think that remmina can't do this at the moment.

But you can use the xfreerdp command from your terminal:

xfreerdp /multimon /u:username /v:server_address:server_port

where username is your username on server, server_address is server location (IP address or hostname) and server_port is port (leave empty without ":" for default port).

If you don't have xfreerdp installed, you can install it from terminal:

sudo apt-get install freerdp2-x11
6
  • I tried to follow your instruction to Win Server 2008 box. Unfortunately getting Error: protocol security negotiation failure error. What can be causing it? – radek Apr 1 '14 at 15:18
  • 1
    I think you may have similar problem as user44439 in this question (see first comment under accepted answer) – betatester07 Apr 3 '14 at 13:18
  • 1
    As in my answer to that question, the default installed xfreerdp for Trusty is 1.0.1 which has no Multimon support - you need the newer version. In addition, be sure that your target RDP server supports it - Windows 7 "Professional" does not (presumably to encourage you to upgrade). – Adrian Jun 19 '14 at 8:22
  • 2
    /d:domain may be useful too – Andy Joiner Jun 5 '15 at 14:43
  • 1
    @user230910: as there's not an option to use multiple displays in Remmina 1.2.0-rcgit-29 (git rcgit-29) which is in Ubuntu official repos, I guess that yes, it's still the case – edison23 Sep 25 '18 at 14:45
2

I figured out a workaround for RDPing into Windows. Create a .rdp file in windows, open it with a text editor, make sure multimonitor is set to 1. Copy it to your Linux system, open with Remmina in windowed mode (not full screen), and connect. In the left pane, click the TOGGLE DYNAMIC RESOLUTION UPDATE, leaving in window stretch to all your display, and voila!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.