1

sudo ppa-purge ppa:ubuntu-x-swat/x-updates

I've tried running that command... several times. Copy/pasted it, manually typed it, tried it in XTerm and Terminal, to no avail. The output is always:

Could not find package list for PPA: ubuntu-x-swat x-updates

There is no / in that output, which leads me to believe it's processing the / as a space and trying to find a PPA named exactly that.

How can I fix this?

3
  • Try quoting (ie sudo ppa-purge "ppa:ubuntu-x-swat/x-updates") the PPA name?
    – kiri
    Sep 11, 2013 at 3:54
  • Quoting the PPA name doesn't help either; the same /-less output is posted. Sep 11, 2013 at 4:22
  • Does this happen with other PPAs or just the x updates PPA?
    – kiri
    Sep 11, 2013 at 4:26

2 Answers 2

1

I believe that's just a misleading error message. A quick glance at the source reveals that it's printing a space where we'd normally type a slash:

warn "Could not find package list for PPA: $PPAOWNER $PPANAME"

So why couldn't it find the package list?

I believe that part of the message is also misleading. You'll likely find that there are, in fact, valid package lists for the PPA in /var/lib/apt/lists/:

$ ls /var/lib/apt/lists/ppa.launchpad.net_ubuntu-x-swat_x-updates_*_Packages
/var/lib/apt/lists/ppa.launchpad.net_ubuntu-x-swat_x-updates_ubuntu_dists_raring_main_binary-amd64_Packages
/var/lib/apt/lists/ppa.launchpad.net_ubuntu-x-swat_x-updates_ubuntu_dists_raring_main_binary-i386_Packages

The thing that's throwing off ppa-purge is that they're empty:

$ file /var/lib/apt/lists/ppa.launchpad.net_ubuntu-x-swat_x-updates_*_Packages
/var/lib/apt/lists/ppa.launchpad.net_ubuntu-x-swat_x-updates_ubuntu_dists_raring_main_binary-amd64_Packages: empty
/var/lib/apt/lists/ppa.launchpad.net_ubuntu-x-swat_x-updates_ubuntu_dists_raring_main_binary-i386_Packages:  empty

It assumes that a repository will always contain packages, and that assumption doesn't hold true for ubuntu-x-swat/x-updates, which at the moment doesn't have any packages for Raring.

If you'd like to remove the PPA, you should be able to use apt-add-repository to remove it from the software sources.

It would also be courteous to let the developers of ppa-purge know about this exception so they can make it respond more helpfully in the future. You can open a bug report by running ubuntu-bug ppa-purge.

0

Try remove Xorg Edgers ppa. Simply run

ppa-purge xorg-edgers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.