2

Whenever I plug in my Canon camera via USB, it gets locked, so when I run gphoto2, I get:

Error (-60: 'Could not lock the device')

Weeks ago, when I first connected the camera, a dialog asked me, "What to do when a medium with photos is mounted?" And I selected, "Do Nothing." But still the camera gets locked.

Once it's locked, and a camera icon appears in the Unity left-side icon bar, I can right-click it and choose "Unmount." Then gphoto2 can connect to the camera. But it would be better if the camera didn't get locked immediately on connection. Any advice appreciated.

If it matters, the gphoto2 command I'm running is:

$ gphoto2 -P -T
1

There is a way to disable auto-mounting in Gnome. Run dconf-editor and in the section org.gnome.desktop.media-handling you can disable automount option. See this answer.

Unfortunately, this prevents auto-mounting all devices, including flash drives, which is probably not desired. Personally, I have reset the action upon insertion of media with photos to Ask what to do (System-Settings - Details - Removable Media - Photos). That allows to unmount the camera right from the dialog shown after insertion, which saves one click.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.