0

When I log into the Gnome session, the shell does not launch.

In terminal I get the following:

pst007x@pst007x-Serval-Professional:~$ gnome-shell
Window manager warning: Screen 0 on display ":0" already has a window manager; try using the --replace option to replace the current window manager.
pst007x@pst007x-Serval-Professional:~$ 

How can I find the current window manager?

If I change the window manager will it break Unity?

Any suggestion?

Thanks

Ubuntu 13.04 64bit Gnome 3.8

EDIT:

Removed Compiz and Unity, then Gnome-shell worked... Guess it's a conflict somewhere

  • try to reconfigure your login manager using sudo dpkg-reconfigure lightdm – Josh Sep 10 '13 at 22:28
0

Try running gnome-shell with the -r (replace) option:

gnome-shell --replace

or

gnome-shell -r

should replace the current running window manager (if that is what you want!). If you want to use gnome-shell by default, reconfigure your login manager with sudo dpkg-reconfigure lightdm (as suggested by Josh) to have the option of selecting gnome-shell session at your login screen.

  • Thanks tried this, but the shell wouldn't start. I installed KDE, and removed Compiz, then it worked, but lost Unity. I may stick with Kubuntu, seems ok.. Thanks again – pst007x Oct 19 '13 at 10:01
0

Removed Compiz and Unity, then Gnome-shell worked... Guess it's a conflict somewhere

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.