I'm having a problem installing Ubuntu, and Kali as well. I downloaded the iso from the official site & tried installing using USB. I also tried desktop installation, but the problem is same.

It shows a single drive i.e. my total Hard Disk and if I select it, it asks me to create a new partition & shows total space as FREE.

It's with all Ubuntu I downloaded, 11.10 Server, 12.10 and 13.04. I also tried to install BackTrack's new version Kali Linux but again I got the same problem.

I hope I meet thier system requirements. Here's my system details for your ease:

  • OS: Windows 7 Ultimate
  • Processor: Intel P4 2.80 GHz
  • RAM: 3GB
  • Hard Disk: 320GB
  • No of Local Drives: 4 (1 Primary, 3 Logical)
  • Free Space: 195GB (about)
  • Motherboard: G31
  • Cache: 1MB Help me, please.
  • Will this, delete the data on the Windows partition? Apr 26, 2014 at 8:56
  • If it's not recognizing your partitions, of course it will then. Apr 26, 2014 at 10:29

4 Answers 4


I had the exact same problem with dual booting Ubuntu and Windows on an HDD. Here is the solution to MBR and GPT problem: Boot from USB Stack or CD/DVD and select Try Ubuntu.

  1. In the terminal while “booted” from the live CD type sudo gdisk /dev/sda (change /dev/sda to whatever is appropriate to access your hard disk, if necessary). The program is likely to complain that it’s found both MBR and GPT data, and will ask which to use. It doesn’t matter which you tell it to use.
  2. At the “Command” prompt, type “x” to enter the experts’ menu.
  3. At the “Expert command” prompt, type “z” to “zap” (destroy) the GPT data.
  4. Type “y” in response to the confirmation about destroying the GPT.
  5. Type “n” in response to the query about blanking the MBR. Caution: If you answer “y” here, you’ll destroy your Windows partition(s)!

There! Problem solved!


This symptom is usually caused by one of two problems:

  • Leftover software RAID data -- If the disk had been (or is being) used with software RAID, leftover RAID data can confuse the Ubuntu installer. You can usually fix this problem by typing sudo dmraid -E -r /dev/sda; however, you should be very sure that you're not currently using software RAID. If you erase RAID data when the system is actually using RAID, the result can be problems accessing your disk at all.
  • A damaged partition table -- The libparted library (upon which the Ubuntu installer relies) is extremely sensitive to partition table problems. If any exist, it usually reports the disk as being empty. My FixParts program (part of the gdisk package in Ubuntu) will correct many of these problems in an automatic or semi-automatic mannger; see its Web page for details. Other problems may require more specialized and manual repairs. If you think this is the source of the problem and if FixParts can't fix it or if you're wary of using FixParts, post the output of sudo fdisk -l /dev/sda. (Add four spaces to the beginning of each line of that output to preserve columnar output.)
  • Sorry, I am completely unknown about RAID. I don't know whether it was using RAID or not, and I'm not a linux user. I am a newbie, if you could help me fix these errors using windows I'd be very greatful to you. I also tried to boot windows using a CD, and it detected my partitions correctly. The problem is with linux only. *I have only 1 primary partition and 3 other partitions are logical partitions. Sep 11, 2013 at 8:47

I had a similar problem trying to install Ubuntu (via USB) alongside Windows 10: the Ubuntu installer did not recognize my SSD and only found the USB drive I was installing from. It turned out to be because I had RAID enabled for the SSD. I tried disabling RAID in the BIOS but then Windows would not boot.

After some searching around, I found a website with instructions on how to disable RAID in Windows: http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/. Here is a summary of the instructions to the best of my understanding:

  • Boot into windows, and set a flag to boot into Safe Mode on the next restart.
  • Reboot and enter the BIOS settings to disable RAID.
  • Exit BIOS settings and boot to Windows. Windows will boot into Safe Mode automatically.
  • Clear the flag to boot into Safe Mode, so the system will boot into normal mode.
  • Reboot.

After disabling RAID by following the instructions on that website, Windows worked with RAID disabled, and I was able to install Ubuntu successfully.


When I'm attempting to install Linux Mint 19 instead of pre-installed Windows 10 on my Dell G7 15 I stacked with a similar problem.

I spend much time trying to change BIOS options. I've tried to enable Legacy External Devices, and Enable Legacy Option ROMs with Enable Attempt Legacy Boot. I've enabled/disabled PTT Security, but without any success.

But what I do next, solved my problem:

  1. Boot my computer and press F12 several times, this should run BIOS boot settings.
  2. Select BIOS setup.
  3. Go to General - Boot Sequence, in Boot list option select UEFI. screenshot #1
  4. Next, go to System Configuration - SATA Operation and select AHCI or Disabled. screenshot #2
  5. Click Apply button and Exit.

After that Linux Live ISO should recognize your SSD. In my case, it was 256GB M.2 PCIe NVMe SSD

  • Can confirm that for another Dell configuration: After switching BIOS SATA Operation from the default "RAID on" to "AHCI", Ubuntu 19.10 found the NVMe SSD on my Latitude 7300 and I was able to proceed with partitioning.
    – mfg
    Dec 25, 2019 at 13:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .