When I close my laptop lid, all my screens are turned off (my laptop screen and my LG M237WA monitor).

I'd like to know how do I make it turn off only the laptop screen and keep the monitor on (I want that behaviour for when I want to watch a movie on my monitor and don't want any brightness coming for the laptop screen).

I'm using a HP Pavilion dv4-1290br, which comes with a nVidia GeForce 8400M GTS. I'm using the nVidia driver and it's working perfectly. For my X settings, I'm using TwinView, my laptop is set to 1280x800 and my monitor to 1920x1080.

I hope you guys can help me, for I couldn't find anything so far.

Thank you very much.

  • 1
    Hi, I have a Fn function to turn off laptop monitor. Have you got same?
    – antivirtel
    Apr 10, 2011 at 13:59
  • Thought this was duplicate of askubuntu.com/questions/15520/…, but I think you want to keep the external screen on but DPMS the screen off on your laptop screen? Not sure that's possible, but perhaps someone will answer.
    – Scaine
    Apr 10, 2011 at 14:03

2 Answers 2


Find the Name of displays by run xrandr in terminal(your laptop screen is something like LVDS1, and your external monitor is some thing like VGA).

# turn off laptop screen
xrandr --output LVDS1 --off   

If you need to turn on the laptop screen::

# laptop screen on
xrandr --output LVDS --mode 1280x800

If you want to turn off external screen::

xrandr --output VGA --off

If I have understood your problem correctly you want an external monitor to watch film without the laptop screen in the way?

You can shutdown the power to the laptop screen by using your external monitor program or a keyboard shortcut.

It would really help with some screenshots of your external monitor program, which program is it?

  • It's the nVidia driver...
    – jpmelos
    Apr 12, 2011 at 4:06
  • @jpmelos then it's easy! just go to nvidia x server settings --> display configurations and press detect displays, then turn off your laptop screen and just use the external one! :)
    – Alvar
    Feb 9, 2012 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .