7

I am installing bluez 5.8 on Ubuntu 13.40 and while running ./configure, I am getting this error message.

checking systemd system unit dir... configure: error: systemd system unit directory is required

How do I resolve this?

13

I am using Mint 15 and ran into same problem while installing BlueZ 5.8. Googling found your exact question. To solve it, had to add --with-systemdsystemunitdir and --with-systemduserunitdir configure options. Since Mint and Ubuntu have much in common, you may find that it works for you too. The complete command line is below. You may want to leave out the --enable-experimental flag so you don't get experimental plugins.

./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc --localstatedir=/var --enable-experimental --with-systemdsystemunitdir=/lib/systemd/system --with-systemduserunitdir=/usr/lib/systemd
3
  • 7
    I did ./configure --disable-systemd and that seems to remove the error. – KTSee Sep 13 '13 at 2:37
  • Welcome to AskUbuntu @mrd. Keep answering like this, and you will be very useful here. – eyoung100 Dec 8 '14 at 22:24
  • good!! work fine – Davide Dec 27 '14 at 11:18
1

Configure it without systemD. It will work like so:

./configure --disable-systemd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.