2

I've a problem which bothers me for days:

The audio output via HDMI does not work anymore since I updated to Ubuntu 13.04 (it worked perfect with ubuntu 12).

A few datas:

**cat /proc/version**
Linux version 3.8.0-30-generic (buildd@akateko) (gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1) ) #44-Ubuntu SMP Thu Aug 22 20:54:42 UTC 2013


**aplay -l**
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: Intel [HDA Intel], Gerät 0: ALC262 Analog [ALC262 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: Intel [HDA Intel], Gerät 3: ALC262 Digital [ALC262 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

What I've tried so far:

  • updated the kernel to 3.9 mainline, but after that my keyboard stopped working (roll back).
  • checked alsamixer that everything is unmuted.
  • run pavucontrol, to check the sound-output (I can see the correct output device and the bar indicator moved, but i can't hear anything)
  • in the audio-settings „HDMI/Displayport“ is selected
  • installed the newest version of alsa-daily

I red so many threads, but nothing resolves this issue. I would be very grateful if you could help me with this.

Best regards.

I wanted to mention that I am a real ubuntu beginner ;)

0

I know this is an odd set of steps to follow, however I found the following to work each and every time on my i7/7th Gen NUC from MicroCenter, where sound worked throught the headphone jack, but not through HDMI. Only thing is...I don't have a clue as to WHY it works.

Note:

Read this before doing it. Write down the steps so you can get back to the desktop.

Steps:

Open up Youtube.com to any video, so that you will hear sound when it comes back on. Enter TTYL Terminal by simultaneously pressing the keys Ctrl+Alt+F1 Exit TTYL Terminal by simultaneously pressing hitting the keys Ctrl+Alt+F7 The sound should be working now. Background:

I originally found this solution (AFTER HOURS OF RESEARCH) by accident because I needed to enter the TTYL terminal to initially set my root user's password without restarting. As soon as I logged in as my user (before resetting any passwords) the sound randomly started working. Eventually, I found that simply entering TTYL terminal and returning to the desktop while audio SHOULD be playing caused it to work as expected ... UNTIL RESTARTING.

SO,

This solution ONLY works for the current session. If your computer restarts for any reason, you will have to again perform this action.

If you find any other information on this, including a more permanent fix, please inform so that everyone can act on it!

Thanks,

Joseph

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.