I have downloaded and installed Intel's drivers from this link, following all instructions: https://01.org/linuxgraphics/downloads/2013/intelr-linux-graphics-installer-version-1.0.2

However, I would like to return to stock Ubuntu's driver configuration. How would I go about doing this? I've found this link, but it's only for Ubuntu 12.10: http://theclonker.de/?p=89

According to Synaptic, Intel's repository added the following packages locally (may contain typos; forgive me):


I'm not sure whether the above list is complete and/or exhaustive as to the changes the Intel installer made.

Also important to note, Intel's instructions to delete their repository in Software Sources just flat-out doesn't work. It removes the repository, but keeps the packages installed locally.

  • I checked the link.. The script was actually only for 12.10 But the steps after that script actually applies for all versions and distros.. So you have to replace quantal* to raring* in Pin: release a=quantal* if you are using Ubuntu 13.04. or quntal* to precise* if your are using Ubuntu 12.04 that was mentioned clearly there.. Obviously apt-get is already installed.. – Saurav Kumar Sep 9 '13 at 15:58
  • possible duplicate of How to safely remove proprietary Intel driver – Mateo Oct 27 '14 at 17:01

All right. I have a history of answering my own questions, and here goes again:

Thanks to Saurav Kumar, I had another look at the second link I put in my question. Here's what you gotta do in Ubuntu 13.04:

Open the terminal and create a new file:

gksudo gedit /etc/apt/preferences.d/intel-removal

Copy+paste the following contents (MAKE SURE THAT THERE ARE NO TABS, SPACES OR INDENTS BEFORE ANY LINES, and replace raring with your own release):

Package: *
Pin: release a=raring*
Pin-Priority: 1001

Package: *
Pin: origin download.01.org
Pin-Priority: -100

Save the file and close gedit.


sudo apt-get dist-upgrade

In my case, this simply downgraded and removed some packages. I cannot guarantee what it will do on your system, because I'm a noob like that. So run at your own leisure, but don't blame me if things go wrong.

Now the cleaning up bit:

sudo rm /etc/apt/preferences.d/intel-removal
sudo rm /etc/apt/sources.list.d/intellinuxgraphics.list*
sudo apt-get update

Followed by removing the actual drivers (i915-3.9-3.8-dkms WILL be different depending on your version of Ubuntu):

sudo apt-get purge i915-3.9-3.8-dkms intel-linux-graphics-installer
sudo apt-get autoremove

Reboot, et voilà, we're done. Thanks to the author of the below blog post and Saurav Kumar.

Reference: http://theclonker.de/?p=89

|improve this answer|||||
  • 2
    It is good that you verified it first, also posted an answer.. Definitely it would help others to get ride of such things.. – Saurav Kumar Sep 9 '13 at 16:25
  • 4
    Great, this worked for me on 14.04.1 with changing the 2nd line Pin: release a=raring* to Pin: release a=trusty* – Omer Sabic Aug 10 '14 at 12:14
  • Worked wonderfully for me on 15.10 as well. Thanks for the tip. – navjotjsingh Mar 21 '16 at 6:58

I would like to add that installing the intel-driver messes with nvidia and bumblebee.
So if you get

[ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[ERROR]Aborting because fallback start is disabled.

when trying to run optirun something, the answer above will solve your problem.
Took me 2 hours of google to figure that out...

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.