1

I'm running an Acer laptop on 13.04:

3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The laptop has an SD/MMC card slot that has worked for me in the past. Now, however, when I insert an SD card (one that works in Windows), the kernel sees it but doesn't do anything with it:

Sep  9 10:02:49 adina-wired kernel: [   52.552869] mmc0: new high speed SDHC card at address 0001
Sep  9 10:02:49 adina-wired kernel: [   52.557819] mmcblk0: mmc0:0001 00000 7.46 GiB 
Sep  9 10:02:49 adina-wired kernel: [   52.558974]  mmcblk0: p1

Normally there'd be the part where it actually adds a /dev/sdx mapping, but that doesn't happen. I've tried two working SD cards with exactly the same results.

I can provide lsusb, lspci, etc if that'd help. This sort of thing happens every now and then and I'm really mostly trying to learn how to poke around and diagnose the issue.

1

The device you are looking for is /dev/mmcblk0p1

  • Well durr. So the problem is likely just a udev thing, where there's no rule to match the device signature? (Oh, and by "well durr" I mean that I feel stupid, not that your answer isn't exactly right, which it is :) – Pointy Sep 9 '13 at 15:31
  • @Pointy, no, sd is for scsi disks. MMC cards show up as mmcblk. – psusi Sep 9 '13 at 15:50
  • @psusi well in the past I'm kind-of sure I've always had them show up as /dev/sd (just like my SATA drives, which aren't scsi disks either). However it's not an issue if they're being mapped to something unexpected now that I know to expect it! Thanks. – Pointy Sep 9 '13 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.