0

I have dual boot Windows 8 and Ubunu 13.04 (secure & fast boot off, C:\ win8, D:\ shared partition NTFS, and 2 ext4 partitions for ubuntu \ and \home). When I'm in Ubuntu, everything works fine, but when I start Windows 8 and run "Error checking" there are errors. Windows fixes it, but sometimes files are missing from D:\ or they are corrupted (like 0 B size)...

Fast boot is disabled (bcdedit /set disabledynamictick yes) - no change.

Hibernation disabled (powercfg /h off) - no change.

I have important documents on D:\ drive and I'm afraid to open any of them in Ubuntu and then run Windows 8.

Any ideas...???

Thanks...

1

You need to disable the "fast startup" feature in Windows, as described on this Windows site (among many others). The "fast boot" feature in the firmware is relatively unimportant. The Windows "fast startup" feature, though, turns the shutdown process into a suspend-to-disk operation. When this is done, filesystems are not properly shut down, so when a filesystem is accessed in Linux, damage can result.

  • I disabled both - fastboot in bios and fast startup in windows... I even completely disabled hibernation (powercfg /h off)... still, problem remains... I don't know what else to try... – Daniel Sep 9 '13 at 15:02
  • Make sure you're not sleeping either. – ubfan1 Sep 9 '13 at 15:31
  • Are you shutting down properly? You must use a proper software shutdown option in both OSes. If you just hit the power button or pull the plug, the filesystems will be left in an inconsistent state, which can result in errors. – Rod Smith Sep 9 '13 at 19:24
  • I shut down correctly on both OSs... Fast boot, Fast startup and hibernation disabled... today I booted into windows 8 for 2 minutes, then restarted PC back to Ubuntu and suddenly ubuntu cannot access some files on NTFS partition: "This location could not be displayed... Error when getting information for file... Input/output error..." – Daniel Sep 11 '13 at 15:38
  • Re-check that you've disabled the Windows fast startup feature. There's also a chance that you've got a hardware problem. This could be a bad cable or a failing hard disk, so running SMART tests on the disk (using smartctl, GSmartControl, or Palimpsest Disk Utility) may be worth trying. Another thing to check is the kernel ring buffer: Type dmesg | tail to see recent entries after you try to access files on the NTFS volume. There may be some clues about what's going wrong in there. – Rod Smith Sep 11 '13 at 16:58
1

Nothing worked... Windows always corrupts files while booting...

So, I found workaround: before I shut down Windows I unmount D:\ with a *.bat file that contains the command

mountvol D:\ /D 

and after I boot into windows again, I use another *.bat file with the command

mountvol D: 'VolumeName'

to mount the drive.

This way windows doesn't have access to D:\ while shutting down or booting...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.