I have a Samsung laptop NP350E7C. It comes with Windows 8 and I'm trying to install Ubuntu 13.04. The first time I installed it with the live USB, it worked, but windows stopped working. I repaired windows and now there is not way to reboot on Ubuntu. I even tried to use windows' boot manager instead of GRUB2 with no success.

I then followed the instructions at http://doc.ubuntu-fr.org/uefi?redirect=1 (disabled fastboot and secureboot in the BIOS) and re-installed ubuntu. I then had the windows blue screen as predicted by this tutorial and I could repair it with the instructions from their link.

Than, I needed to repair ubuntu's boot with boot-repair. Using the recommended options, I always get to this error:

An error occurred during the repair.

Locked-ESP detected. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair].

According to this thread http://ubuntuforums.org/showthread.php?t=2112273 the problem is that the file /EFI/ubuntu/grubx64.efi is corrupted and then if we can remove it and run boot repair again, everything should work fine. I then removed the file using the instructions at How can I remove Ubuntu from the UEFI boot options? but every time, I run boot repair I still get the same error.

My logs are at http://paste.ubuntu.com/6081052/

Any help is very appreciated. Thanks again


See this bug report. It includes a workaround, which I quote:

  1. via Gparted create another EFI partition (FAT32, 200MB, located in the first 100GB of the disk)
  2. move the 'boot' flag on it
  3. make Ubuntu use this new ESP (eg via Boot-Repair --> Recommended Repair).

See also the error message that you quoted in your question.

  • I'll try this, but Iḿ not sure that it's the same case. I'm able to create /EFI/ubuntu folder with a file in it. I wonder if the problem is that I used the windows boot loader first... – duduklein Sep 9 '13 at 5:00
  • Sorry for the delay. I did this, but bootrepair does not recognize the new boot/efi partition. When i choose the advanced options to select the which partition to use, the one marked with the boot flag does not show up in the list. – duduklein Nov 3 '13 at 8:36
  • In that case, try using the USB flash drive or CD-R version of my rEFInd boot manager. If Linux is installed except for the boot loader, rEFInd should get Linux booting. If that works, try installing the Debian-package version of rEFInd. That would normally install it on your hard disk; however, it's possible that whatever's blocking GRUB and Boot Repair will also affect rEFInd, in which case you may need to jump through some more hoops. – Rod Smith Nov 3 '13 at 14:14

In my case (using Boot-Repair from within a Ubuntu Live USB, as explained in the 2nd option of the Boot-Repair wiki), the Locked-ESP error was caused by my partitions being mounted.

I unmounted them using gParted (right-click on each partition -> unmount), and then Boot-Repair succeeded in repairing my system (using Recommended Repair).

See also this article.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.