This is what I've done:

  • Installed Tor:

    sudo apt-get install tor 
  • Installed Vidalia using the Ubuntu Software Center

I then started Vidalia and it said Tor is not running including an error message saying that Vidalia was unable to start Tor.

Tor not running

I searched a bit and I've found out that the problem can be that Tor is already running when Vidalia gets started.

These were my further steps:

  • Removed Tor from the runlevels

    sudo update-rc.d -f tor remove 
  • Killed all Tor processes

    sudo pkill -x tor 

Vidialia still displayed the same error messages upon starting it.

The path to Tor in the settings should actually be correct:


I verified its existence.

However, I cannot click OK in the settings dialog because the ControlSocket path does not exist. It defaults to /var/run/tor/control

I then activated the Control Socket 9051 in Tor's configuration file (/etc/tor/torrc) and edited Vidalia's settings accordingly. I also reset Vidalia's path to that Tor config file.

Unfortunately, I'm still getting the same error as above!


3 Answers 3


OP posted:

I tried to manually start Tor (by typing /usr/sbin/tor in the terminal) and afterwards Vidalia and it works perfectly.

From the documentation of Vidalia:

I Can't Start Tor

The most likely reason that Vidalia could not start Tor is because Vidalia is looking for your Tor installation in the wrong directory. You can tell Vidalia where Tor is located by updating the Tor Executable option in the general configuration settings. Another possible reason that Tor cannot start is because there is already another Tor process running. Check your list of running process and stop the previous Tor process, if you find one. Then, try running Tor again.

If that did not help, check your message log to see if Tor printed any information about errors it encountered while trying to start.

Vidalia Can't Connect to Tor

Vidalia manages Tor by communicating with it via Tor's control port.

The most common reason that Vidalia cannot connect to Tor is because Tor started, but encountered an error and exited immediately. You should check your message log to see if Tor reported any errors while it started.

If Tor is listening on a different port than Vidalia expects, Vidalia will be unable to connect to Tor. You rarely need to change this setting, but if there is another service running on your machine that conflicts with Tor's control port, you will need to specify a different port. You can change this setting in Vidalia's advanced configuration settings.

Tor Exited Unexpectedly

If Tor exits immediately after trying to start, you most likely have another Tor process already running. Check the message log to see if any of the last few messages in the list are highlighted in yellow and contain a message similar to the following:

connection_create_listener(): Could not bind to Address already in use. 
Is Tor already running?

If you find an error message like the one above, you will need to stop the other Tor process before starting a new one with Vidalia. On Windows, you would need to look for tor.exe in your Task Manager. On most other operating systems, the ps command can help you find the other Tor process.

If Tor had been running successfully for awhile (that is, longer than a few seconds), then you should check the message log for information about any errors Tor experienced before it exited. Such errors will be highlighted in either red or yellow.

  • I would have posted this answer myself if I regarded it as a satisfying solution. I search for a way of not having to start Tor manually.
    – ComFreek
    Sep 8, 2013 at 16:26
  • Thanks for clarifying this. (I didn't want to provide the solution in the question as it isn't/wasn't one).
    – ComFreek
    Sep 8, 2013 at 16:38

On terminal

sudo ln -s /etc/apparmor.d/usr.bin.vidalia /etc/apparmor.d/disable/ sudo apparmor_parser -R /etc/apparmor.d/usr.bin.vidalia sudo /etc/init.d/tor start

and then

  • answer without explaining? Sep 15, 2014 at 14:27
  • There is a thing called apparmor in ubuntu which helps to restrict applications to some resources. Vidalia is in its list by default. So by these commands we are disabling it from its list and restarting Tor Sep 16, 2014 at 5:00

Then, restart privoxy and polipo

sudo /etc/init.d/privoxy force-reload && /etc/init.d/polipo restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.