I have an HP pen-drive that has 16GB space. If I add a file to it, and then I delete that file, the free space of that deleted file doesn't get applied. The only way I've found to see that space as available again is by deleting the partition and doing it all over again!

Why is this? Any clue?

I've used KDE Partition Manager to create the NTFS partition.


I have found that nautilus changed behaviour sometime in the last year from actually deleting files on removable media to putting them into a hidden directory named .Trash or similar in the top-level directory of the media.

This is great for "oops"es, but did catch me unawares the first time I "deleted" 2GB of a 4GB thumb and still had no extra space.

I didn't explore if Empty Trash was available or worked, I just rm -rf the offending directory.

| improve this answer | |
  • 5
    Yeah, I'm pretty sure emptying Trash works as well. In previous versions of Ubuntu, I've seen that when you "Unmount" or "Safely Remove" the drive, you'll get a prompt asking you if you'd like to really delete the files. Don't know what happened to that, though :-\ I'm running 10.04 for the record. – Naftuli Kay Apr 10 '11 at 4:23

To avoid all this, try using the shift+delete functionality. This way, deleted files do not go to trash. This is described in How to delete files bypassing trash

| improve this answer | |

In Nautilus, use the 'Show Hidden Files' option off the 'View' menu.

You should then see the '.Trash' folder. You can now Shift+Delete that folder, freeing up the space.

| improve this answer | |
  • This is by far the easiest solution. And also functions with Nemo. – Luís de Sousa Sep 21 '15 at 8:21

I have seen this happen a couple of times; I have solved this by ejecting the USB key. Then nautilus then goes and soft of commits the changes you made to the USB stick. weird I know, but it seems to have worked for me.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.